How to ban an IP address from spamming my zenphoto

I have been spammed for the last four months and need a way to block an ip address from posting on my site.

Is this possible.

Comments

  • At the moment I have restricted comments to registered users only.

    But this is not what I want.

    I would like to permanentaly ban ip addesses if possible.
  • acrylian Administrator
    Options > Comment > Spamfilter set to "simple". Or use a third party spamfilter like Akismet (see extensions section).

    Or do it on your server directly via htaccess or else (ask your host).
  • There is a plugin to block ip addresses when hackers try to log on unsuccessfully--`failed_access_blocker`. It could easily be extended to block an arbitrary ip. Perhaps that would be a good new feature request to make. Won't make it to the 1.4.3 release, though. Missed the cutoff.
  • Also, I did create a project-honeypot plugin. Once done my spam has gone to next to nil. I'm not sure how many others have used it, but I'd be interested to see if it fixes your situation.

    Edit: zenHttpbl is the plugin name.
  • Micheall: Check the link from Zenphoto's extensions to your site. Right now I get a "not found"
  • acrylian Administrator
    Micheall, you should check your server and host... My browser reports "Could not open site. Cannot find the server".
  • Odd, I'm not experiencing any issues on this end. And yes the link in extensions is correct. Course you both put that a few hours ago, wonder if I had a downtime. :( Seems fine now on my end though.
  • acrylian Administrator
    Sorry, your site is still not accessible to me. No browser still can find the server.
  • @acrylian - I believe it's all working now. Can you verify that the site is accessible?
  • I have horrible luck, lol. Figured out what it was, combination of buggy DNS and then my domain expired and I never got a notification, renewed so should be resolved within the next day or so while it re-propogates again.
  • acrylian Administrator
    Yes, seems I can access the site but setup wants to run which I of course can't. I guess the changes make Zenphoto think something is new...:-)
Sign In or Register to comment.