Images poorly found by Google

I'm using the sitemap extension and added the sitemap on my Google webmaster tools page. But all of my images (5000+) are poorly indexed by Google, even the ones I added including iptc info, unique title and descriptions. Anyone else who noticed this?

Comments

  • acrylian Administrator
    Are your albums and cache folders accessible, how does your robots.txt look like?

    Google just changed its algorithms recently which apparent threw a lot of sites and pages out of the index. The whole seo industry talked about that. Maybe they don't like pure image galleries anymore... Always a little mystery what Google does and not..

    If I search for "site:www.jacktummers.nl" I get 5200+ image results and so far all from your site. So bad it cannot be then..
  • Those 5200+ images are mostly from my blog I think (2200+ posts), but some of them perhaps within a ZP album. It's just that when I search for an image by name (in this case 'Diederik Stapel'), my photographs are on the top of the page, but via other websites, not mine :(

    My robots.txt is rather empty:

    `
    # BEGIN XML-SITEMAP-PLUGIN
    Sitemap: http://www.jacktummers.nl/sitemap.xml
    # END XML-SITEMAP-PLUGIN

    User-agent: *
    Disallow: /wp-admin/
    Disallow: /includes/

    Sitemap: http://www.jacktummers.nl/collectie/index.php?sitemap
    `
  • acrylian Administrator
    Zenphoto has its own robots.txt by default and that was very strict by default by blocking even the image cache, which of course means Google cannot index the images there. Do you use that?

    If I look at your Zenphoto sitemap or more specifially the sub sitemaps I see that you are using the Google image option. We had built in that based on an contribution. I never used it myself but links like `http://www.jacktummers.nl/collectie/zp-core/i.php?a=beeldbank/buitenland&i=ardeche-2011-073.jpg&s=600&cw=&ch=&q=70&wmk=!` are of course no direct image links. Try to clear and regenrated the sitemaps so they don't link to the image processor but the cached images itself. Probably google does not like these links.

    Also try to use the latest 1.4.2.4 release. I am not sure if or when we did work on the sitemap. At least for the coming 1.4.3 a few things have been improved (if I recall right).
  • Damn! I overlooked the robots.txt of ZP. It said disallow /albums and /cache. Should I allow access to both or just /albums?

    I turned on the Google image option just a few days ago, hoping that will help. I will turn it off again.

    With all this, I hope my images are going to be found. Thanks for you advice :)
  • acrylian Administrator
    If you allow both /albums and /cache depends if you want your full images to be found or just the sized ones.

    Btw, the default robots.txt for 1.4.3 will by default allow the caches (image/html) to be indexed now. I just did add that as I meant to have done that before but apparently forgot.
  • Since I don't use sized images (my images are already the right size), I will disallow the cache directories. They contain only the thumbs anyway.
  • acrylian Administrator
    Ok, you know that Zenphoto sizes any image to save filesystem checks if cached or not even then? You have to modify the theme if you want to use the full ones directly on the image pages.
Sign In or Register to comment.