Message when "leaving" a page

Many times when I click on something in the admin panels, I'm presented with an annoyance:
https://pbs.twimg.com/media/CKsFxj0VAAE6R-I.png:large

So that's a message that asks me if I really want to leave the page, because unsaved data may get lost.

This happens so much that it has truly become nothing more than an annoyance. It doesn't add any safety. Moreover, it happily displays itself even when I literally haven't touched ANY of the fields on a page.

Should be fixed.

Comments

  • acrylian Administrator
    I cannot reproduce that actually. What browser are your using (incl. version please)?

    As mentioned elsewhere already it might be autofill enabled in the browser that is filling hidden form elements possibly. Please disable that setting and try again. If it still happens it is something else.

    Autocomplete can be set on form fields but some tests a while ago by my colleague showed that especially Chrome just ignored that.
  • thany Member
    I'm not aware of any autofill plugins installed. I'm using Firefox 39.0, which doesn't autofill anything by itself.

    Well, Firefox does autofill username/e-mail address/password fields when I thinks it encounters them, so in that case, IF that's the case, it's a simple matter of giving those fields a better name (as in, the `name` attribute).
  • gjr Member

    Well, Firefox does autofill username/e-mail address/password fields when I thinks it encounters them, so in that case, IF that's the case, it's a simple matter of giving those fields a better name (as in, the name attribute)

    We are always looking for contributions, especially simple ones.
  • thany Member
    When I have time to dive into the code, I'll see if I can fix this (since this is my only real irritation from zenphoto)... But right now, sad to say I don't have that time ;)
  • acrylian Administrator
    Well, same here especially since we don't encounter that ;-)
  • MarkRH Member
    I use Firefox 39.0 and I can click all over the admin stuff, editing images or albums and don't get that message. Only if I type something and the Apply button turns green do I get that message.

    Now then, I don't have Firefox remember username/passwords as I use Roboform instead.
  • thany Member
    I should hope there's no username/password fields anywhere other than at the login page... That's just about the only thing Firefox will autofill.

    If that's not it, *something* must be triggering this message, and whatever that something is, is looking at too many fields, or doing something wrong.

    But even IF I change something, that message is still an annoyance. I'm a poweruser and when I navigate away from a page, I know very well what'll happen to unsaved data. I want to be able to disable that message completely, especially if this bug won't be resolved anytime soon.
  • acrylian Administrator
    I don't get this in any browser I have (Firefox, Safari, Chrome). Problem is if we can't reproduce it, we can't solve it and therefore cannot confirm it a bug.

    If anyone else has this issue please tell so, otherwise it is so far just you. I know that will not satisfy you but that's how it looks currently.
  • gjr Member

    I should hope there's no username/password fields anywhere other than at the login page... That's just about the only thing Firefox will autofill.

    There are username/password fields on every object page that can be password protected, they are just hidden until the lock is clicked to reveal. For example, when editing an album click the "Album password" label right below the description, you will see the fields then, probably autofilled by Firefox.

    I used this technique to fix this issue for Chrome:
    http://benjaminjshore.info/2014/05/chrome-auto-fill-honey-pot-hack.html

    Obviously not working for Firefox. Can you set your autofill setting in Firefox to ignore certain domains?
  • This issue persists in the latest version.

    When can we see this fixed?

    I don't want to fiddle with my browser to get one website to work. It should just work on default settings.

    It's literally only ever annoying. It pops up SO much that clicking it away becomes second nature. Which in turn means that when there really is unsaved data, clicking it away has become second nature, and the message is effectively useless.

    Look, just remove this silly functionality, okay? Then we can close this silly issue and move on to more important bits.
  • acrylian Administrator
    It is not a silly functionality as it prevents data loss of unsaved data if leaving the page accidentally.

    Actually we improved this a lot. I personally don't get unexpected warnings but that might be because I have disabled form autocompletion in browsers. Although there is an html attribute to do so on form fields some browser do not follow that.

    It would be helpful to know on which pages you actually get this.
  • It doesn't prevent data loss, it CAUSES data loss.

    Why?

    This message pops up on almost every page, after almost every action. That means users will click the message away on autopilot. Just like deleting a file in windows explorer is "del, enter", the "are you sure" message is total bullshit.

    Now when this message is actually needed for reals, the same user being less alert on "leaving" a page because this so-called preventing data loss is in place, will be clicking this message away on the same autopilot as ever. And poof, gone is the data. So even though you've put something in place that is supposed to prevent data loss, it's actually causing data loss.

    It's silly functionality that doesn't even work, and doesn't add anything effectively.

    You could try to make it work, but you better just remove it.

    Oh and FYI, Firefox will listen very well to autocompletel(-like) attributes on fields. But it does follow the standard. I hope zenphoto does too. And I hope this crap jQuery plugin does as well.
  • acrylian Administrator
    Any CMS has this kind of functionality including the most used one named WordPress.. Sorry if you are annoyed but this function is meant to trigger whenever a form is changed.

    Note that some message are not related to form like those if you want to delete an album, image etc. You might find this not important as you know what you are doing. Sadly not all users do. I have some users/clients using Zenphoto that are far less comfortable with these things and really need this messages to be reminded.
  • WordPress, there you just named the crappest cms in the world. The most used, but not by a long shot the best one.

    If you/they really need these messages, make it work then! The is message is *useless* if it appears at every attempt to navigate to a new page. ANY message that appears too often becomes superfluous. How many times do I need to repeat myself?
  • acrylian Administrator
    Well, WordPress has surely its flaws but generally I don't agree. Besides I would welcome if you could calm down your a little demanding sounding tone a bit.

    I cannot see that constant warnings unless you indeed changed something on a page.
  • I stumbled on this thread while looking for something else, and recognized that I also have seen this quirk.

    When in the Admin options, the Gallery, Image, and Search tabs will all popup the warning about changes not saved when no changes have actually been made.

    I decided to investigate. Turns out that for me, the Lastpass extension in Chrome is the culprit - on the Gallery, Image, and Search tabs there are fields with "password" in the name, and so Lastpass is attempting to help with password entry.

    I doubt there's anything to be done about it, I think it's just something that those of us who use password extensions need to accept.

    At least now I know what causes it, thought I'd share the info.

  • acrylian Administrator
    edited October 2017

    Yes, password fields are the issue. Please try the support build if it works better for you, too.

Sign In or Register to comment.