Cannot enable seo_locale

vlc Member
I'd like to enable the "seo_locale" plugin on my ZP 1.4.12 installation, but I cannot as "This plugin is not compatible with the dynamic locale Use subdomains option".

As far as I understood the "Use subdomains" option must be disabled in the "dynamic locale" plugin (it is). I also tried enabling "Use subdomains", but the problem persists.

Is there anything else I'm supposed to to to enable "seo_locale"?

Thanks a lot in advance,
Christoph

Comments

  • acrylian Administrator
    Yes, if you have the seo_locale enabled you get urls like `example.com/`, e.g. `example.com/en/`.

    The "Use subdomains" uses different urls with subdomains like `.example.com`, e,g. `en.example.com`. Quite logical that using both is at least doubling things.

    General info about multilingual sites here:
    http://www.zenphoto.org/news/multi-lingual-sites/
  • vlc Member
    Thanks for your reply.

    So theoretically, when "Use subdomains" in "dynamic locale" is disabled, I should be able to enable the "seo_locale" plugin (?).

    My problem is that "Use subdomains" is disabled, but ZP keeps insisting that I cannot enable the "seo_locale" plugin because "This plugin is not compatible with the dynamic locale Use subdomains option".

    Now I'm curious why I can't enable the "seo_locale" plugin.
  • acrylian Administrator
    Yes, if "user subdomains" is enabled in dynamic locale seo_locale is not compatible with it. I just tried and all works as expected on my test install.

    Perhaps for unknown reasons the option of the dynamic locale plugin does not stick. Is is really unchecked? Otherwise any errors in the server logs about that?
  • vlc Member
    I select "Options" -> "Plugin" and then "dynamic locale". There the "Use subdomains*" checkbox is unchecked.

    If I now go to "Plugins" -> "SEO" there is no checkbox left of "seo_locale" but an exclamation mark and if I click on this exclamation mark I get the following message: `This plugin is not compatible with the dynamic locale Use subdomains option`.

    The logs (neither debug, security nor setup) show anything suspicious.

    Do I have to run setup again or restart the web server after checking / unchecking "Use subdomains" checkbox?
  • acrylian Administrator
    No, you should not need to re-run setup or restart the server…

    You could check the `options` table in the database itself for the option. That should be 'dynamic_locale_subdomain`. There should be only one entry of this name. If you have more that might indicate an issue with the database.

    That's alll I can think of right now since I cannot reproduce it so far.
  • vlc Member
    I just dumped the database (`mysqldump`) and I can find the string `dynamic_locale_subdomain` only once:

    `(583,0,'dynamic_locale_subdomain','0','','zp-core/zp-extensions/dynamic-locale.php')`

    By the way, restarting the server and running setup didn't help.
  • vlc Member
    Got it: I didn't enable "mod rewrite" in "Options" -> "General".

    You may consider giving a better error description. At least for me it wasn't obvious that `This plugin is not compatible with the dynamic locale Use subdomains option` means that I have to enable "mod rewrite" in the general options.

    Thanks,
    Christoph
  • acrylian Administrator
    Ah, ok, thanks, I have always modrewrite enabled and its fairly standard nowadays. But the message is indeed misleading in this case.
Sign In or Register to comment.