Suddenly locked out

Greetings. When I attempt to log in to my site, as admin, or even try to visit it as a tourist, (user) I get a blank screen except for the top where this text shows up.

Zenphoto has detected a change in your installation.

The change detected may not be critical but you should run setup at your earliest convenience.

I have been looking at the logs but I don't see anything that I can do to fix this. I have uploaded a lot to it in the last few weeks. I accessed the site as late as this morning.

Anyone see this and if so, a solution?

http://www.crookedbear.com

Comments

  • MarkRH Member
    I got a message at the top of mine yesterday like that which was due to MySQL being updated. I just re-ran the setup like it says.

    Now, unlike you, I still saw the rest of my gallery below the text. So, something else might be going on here.
  • acrylian Administrator
    If you get a blank screen that might indicate some error. Please review your server PHP error log about that.

    Otherwise the message to re-run setup always triggers if the install signature of Zenphoto changes. Among things stored is the catalog of files, some core files and the general server config info. So if MySQL is updated it will trigger. It is also documented here:
    http://www.zenphoto.org/news/installation-and-upgrading/#re-running-and-re-uploading-setup-files
    So you need to login via yourdomain.com/admin with your master admin account and re-run setup.

    However, this message should actually not be visible if you are not logged in (e.g. normal visitors). We will look into that.
  • Thank you guys. I almost saved it. Not sure why but nothing I have done at this point has revived it including the excellent answers you gave. They got me mostly there. Last night I resigned myself to a complete reinstall. At that moment, I felt best to research other solutions as well. So we shall see how this goes, pretty sure my comfort with Zenphoto will win out but the process of researching has begone. I hope you all have a great day and thank you so much for the time and help you gave me.

    Cheers.
  • acrylian Administrator
    Sorry for your issues. If you need more help let us know here. Btw, was this a manual install or via some install helper from your host? Just asking as the latter is known to cause issues. We just had another similar topic about that.
  • I did the instal a number of years ago. now they offer a install through some service, softaculous. Thanks again for the help everyone. Research starts tonight so should I reinstall zen I will head your warning.
Sign In or Register to comment.