Warning to run 'Setup'

I am new to Zp and i am in the early stages of setting up my site. However, this morning I got the error message/warning shown below.

As far as I am aware I have not made any changes to my installation.

.....................
Zenphoto has detected a change in your installation.

Your database software has changed from MySQLi 5.6.35 to MySQLi 5.6.36.

The change detected may not be critical but you should run setup at your earliest convenience.
......................

When I click on the 'run setup' link in the message i get another message

...................
You must restore the setup files from the 1.4.14 [f5b47da52f] release.
................
However if i look in 'Overview' that is the Zp version shown.

I have not found any reference to this by searching the forum.

How do I deal with this?

TIA

Keith

Comments

  • fretzl Administrator
    On the "Overview" page look for a button that says:
    Setup » restore scripts and click it.
    Now you should be able to run setup.
    As far as I am aware I have not made any changes to my installation.

    No but your host has updated the database software...as the message says ;-)
  • Thanks for that. Now I know this may be obvious but, how do I run setup again?

    if i go to mysite/zpcore/setup.php i get the same message

    .................
    You must restore the setup files from the 1.4.14 [f5b47da52f] release.
    ..................

    Do i have to run setup from the overview?
    I don't want to reset all settings unless i really have to.
  • acrylian Administrator
    There is a button to restore the files and re-run setup on the overview page. Please also see the installation page on our site for info about that. http://www.zenphoto.org/news/installation-and-upgrading/#re-running-and-re-uploading-setup-files
  • Thanks for the advice. When i looked i could not find the options to re-run set up. However I realized that because i had installed Zp from my hosts Cpanel using 'softaculous' i did not have the setup folder within zp-core.

    I have now added that and all issues have been resolved.

    Many thanks again

    Keith
Sign In or Register to comment.