There might be a bit low responsiveness on technical matters because of some personal family related cirumstances
- Malte (acrylian)

Uploading tiff files in zenphoto gallery

MyAGzenphoto Member
edited October 2017 in General support

Hello,
I have just installed zenphoto and I would like start using it.
The problem is that I want to upload tiff files.

Best Regards.

MyAGzenphoto

«13

Comments

  • acrylian Administrator
    edited October 2017

    Enable the class-anyfile plugin and allow the related suffix. Additionally the class-webdocs plugin also supports tiffs.

    Note: Zenphoto does only support proper web image files which are generally jpg, gif and png only. So you will need a so called sidecar file (search for "video thumb" on the user guide) in that format accompaning those tiff files if using above plugns

    If your server has Imagick installed for image processing you might maybe be able to use tiffs, too. But note that browser might not be able to display them at all. So the any-file way is the best.

  • Hello,
    Thanks for your answer.
    How can I Enable the class-anyfile. which config file do I have to edit ?

    Best Regards.

    MyAGzenphoto

  • acrylian Administrator

    You just enable the plugin on the backend and set the related options.

  • Hello,
    Thanks for your answer.
    Do you mean class-anyfile is a plugin.
    How to install it ?
    where can I download it ?
    Best Regards.

    MyAGzenphoto

  • acrylian Administrator
    edited October 2017

    Again, there is a backend where you can enabe plugins.This plugin is officially included which you can see on our site's plugin's section.

    Each plugin on the backend has an info button which generally gives rough instructions how to use it. This is a plugin you just need to enable, on others you may have to edit the theme used to use its functions. This is also documented on the user guide.

    Please take some time to read on the user guide and get a bit familiar with Zenphoto in general

  • Hello,
    I agree with you, I will start reading the user guide.
    About the backend, I guess you can access it at the following URL:
    "http://zenphoto.private.vki.eu/zenphoto/zp-core/admin.php"
    I could access it till yesterday but what happens now ,is that I get the login prompt and I give zenphotouser as the user
    then the Password is filled by firefox because I have saved it during my first connexion. Although, all I get is a blank page
    I thing I have to initialize the password. How can I do it ?

    Best Regards.

    MyAGzenphoto

  • acrylian Administrator

    If you get a blank page you need to review your server PHP error log. It can be lots of things.

    If you need to reset your password and nothing is working or you didn't set a mail adress, you need to delete in the database. Please also review the user guide on this.

  • Thanks for your fast answer.
    I am going to check the PHP error logs. Maybe I will learn what the problem is from the logs.

  • Hello,
    From now, I can finally load tiff files.
    I could enable the class-anyfile on the backend.
    Thanks a lot for your advices.

    Best Regards.

    MyAGzenphoto

  • Hello,
    Still problems with tiff files.
    Now, when I browse I can see the tiff files in the list but when I click on upload, I get the following message:

    Upload Error
    You have attempted to upload one or more files which are not Zenphoto supported file types

    Best Regards.

    MyAGzenphoto

  • acrylian Administrator

    Please check if you enabled the any-file plugin adn configured it correctly.

    Also review your PHP error log.

  • Hello,

    I have checked the any-file plugin and it is configured correctly.
    Here is my log file:

    {1221:Mon, 23 Oct 2017 11:15:46 GMT} Zenphoto v1.4.11[26c78176cfb8d752e9e7bda4e65d69fc84b714a3]
    
    NOTICE: Trying to get property of non-object in /var/www/html/zenphoto/zp-core/admin-globals.php on line 36
    
    require_once called from admin-plugins.php [9]
    
    {1224:Mon, 23 Oct 2017 11:45:01 GMT}
    
    NOTICE: Undefined variable: stats_albums in /var/www/html/zenphoto/zp-core/utilities/gallery_statistics.php on line 231
    
    printBarGraph called from gallery_statistics.php [646]
    
    {1224:Mon, 23 Oct 2017 11:45:01 GMT}
    
    WARNING: Invalid argument supplied for foreach() in /var/www/html/zenphoto/zp-core/utilities/gallery_statistics.php on line 268
    
    printBarGraph called from gallery_statistics.php [646]
    
    {1220:Mon, 23 Oct 2017 11:45:31 GMT}
    
    NOTICE: Trying to get property of non-object in /var/www/html/zenphoto/zp-core/admin-globals.php on line 36
    
    require_once called from admin-plugins.php [9]
    
    {1082:Mon, 23 Oct 2017 14:24:26 GMT}
    
    WARNING: require_once(/var/www/html/zenphoto/zp-core/../../zp-core/classes.php): failed to open stream: No such file or directory in /var/www/html/zenphoto/zp-core/lib-auth.php on line 44
    
    require_once called from require_once (lib-auth.php [44])
    
    from require_once (auth_zp.php [14])
    
    from require_once (load_objectClasses.php [42])
    
    from require_once (functions.php [33])
    
    from require_once (admin-functions.php [8])
    
    from require_once (admin-globals.php [15])
    
    from admin.php [11]
    
    {1083:Mon, 23 Oct 2017 14:26:04 GMT}
    
    WARNING: require_once(/var/www/html/zenphoto/zp-core/../../zp-core/classes.php): failed to open stream: No such file or directory in /var/www/html/zenphoto/zp-core/lib-auth.php on line 44
    
    require_once called from require_once (lib-auth.php [44])
    
    from require_once (auth_zp.php [14])
    
    from require_once (load_objectClasses.php [42])
    
    from require_once (functions.php [33])
    
    from require_once (admin-functions.php [8])
    
    from require_once (admin-globals.php [15])
    
    from admin.php [11]
    
    {1085:Mon, 23 Oct 2017 14:26:18 GMT}
    
    WARNING: require_once(/var/www/html/zenphoto/zp-core/../../zp-core/classes.php): failed to open stream: No such file or directory in /var/www/html/zenphoto/zp-core/lib-auth.php on line 44
    
    require_once called from require_once (lib-auth.php [44])
    
    from require_once (auth_zp.php [14])
    
    from require_once (load_objectClasses.php [42])
    
    from require_once (functions.php [33])
    
    from require_once (admin-functions.php [8])
    
    from require_once (admin-globals.php [15])
    
    from admin.php [11]
    
    {1093:Wed, 25 Oct 2017 08:21:55 GMT}
    
    NOTICE: Trying to get property of non-object in /var/www/html/zenphoto/zp-core/admin-globals.php on line 36
    
  • acrylian Administrator
    edited October 2017

    There are some issues that are from the other 3rd party plugin I think.
    That is the Zenphoto log, also review the PHP server error log as that might have things Zenphoto's log doesn't.

    I just tried the anyfile class plugin with a .tif and it worked as expected.

    Also please upgrade to the current release which is 1.4.14.

  • Hello,

    Do you mean I should upgrade zenphoto or the ZenLdapLogin plugin ?
    My current version is: Zenphoto version 1.4.11

    Best Regards.

    MyAGzenphoto

  • acrylian Administrator

    Zenphoto. Current is 1.4.11. And for the ldap plugin you should of course use that fork plugin that says it is updated.

  • Hello,
    How can I upgrade from the backend ?
    Best Regards.

    MyAGzenphoto

  • Hello,
    I have just upgaded to zenphoto-1.4.14 and I could enable the class-anyfile on the backend. Again the same error message.
    Here is whatis happening in the log file:

    {1395:Mon, 30 Oct 2017 15:23:58 GMT} Zenphoto v1.4.14[f5b47da52feacae4e5e081b977e60ee0b2fe1bc5]
    
    WARNING: file_put_contents(/var/www/html/zenphoto/robots.txt): failed to open stream: Permission denied in /var/www/html/zenphoto/zp-core/setup/index.php on line 1550
    
    file_put_contents called from index.php [1550]
    
    {1395:Mon, 30 Oct 2017 15:23:58 GMT}
    
    WARNING: fileperms(): stat failed for /var/www/html/zenphoto/cache_html/ in /var/www/html/zenphoto/zp-core/setup/setup-functions.php on line 214
    
    fileperms called from folderCheck (setup-functions.php [214])
    
    from index.php [1595]
    
    {1395:Mon, 30 Oct 2017 15:25:41 GMT}
    
    WARNING: file_put_contents(/var/www/html/zenphoto/robots.txt): failed to open stream: Permission denied in /var/www/html/zenphoto/zp-core/setup/index.php on line 1550
    
    file_put_contents called from index.php [1550]
    
    {1492:Mon, 30 Oct 2017 15:27:24 GMT}
    
    WARNING: file_put_contents(/var/www/html/zenphoto/robots.txt): failed to open stream: Permission denied in /var/www/html/zenphoto/zp-core/setup/index.php on line 1550
    
    file_put_contents called from index.php [1550]
    
    {1498:Mon, 30 Oct 2017 15:28:00 GMT}
    
    WARNING: file_put_contents(/var/www/html/zenphoto/robots.txt): failed to open stream: Permission denied in /var/www/html/zenphoto/zp-core/setup/index.php on line 1550
    
    file_put_contents called from index.php [1550]
    
    {1497:Mon, 30 Oct 2017 15:30:45 GMT}
    
    WARNING: file_put_contents(/var/www/html/zenphoto/robots.txt): failed to open stream: Permission denied in /var/www/html/zenphoto/zp-core/setup/index.php on line 1550
    
    file_put_contents called from index.php [1550]
    
    {1499:Mon, 30 Oct 2017 15:32:05 GMT}
    
    WARNING: file_put_contents(/var/www/html/zenphoto/robots.txt): failed to open stream: Permission denied in /var/www/html/zenphoto/zp-core/setup/index.php on line 1550
    
    file_put_contents called from index.php [1550]
    
  • acrylian Administrator
    edited October 2017

    It's not the same error. This means that file/folder permissions are not set correctly so they could not be set correclty when running setup.
    You will have to do this manually. Please see here: http://www.zenphoto.org/news/permissions-for-zenphoto-files-and-folders/

  • Hello,
    Now I can upload tifs files.
    I have enabled the class-anyfile plugin and allowed the tif suffix in the plugin suffix.
    The only problem I have to solve is the LDAP_login.
    I think, I will start installing the ZenLdap plugin on this version of zenphoto and then we will see.
    Best Regards.

    MyAGzenphoto

  • Hello,
    I though it was OK with this issue but I think we still have to investigate on the tiff issue, because now I can upload tiff files but the problem is that I cannot display in my gallery the tiff that I have just uploaded.
    Any idea ?

    Best Regards.

    MyAGzenphoto

  • acrylian Administrator

    You cannot dispaly the tiff directyl because basically no browser can display tiffs as this is simply not a web image format. This is not a Zenphoto limitation.

    If you like to see thumbs and an preview image you need to provide a sidecar image (also called "video thumb" often as it was originally with that feature): http://www.zenphoto.org/news/problems-with-albums-and-images/#thumbnails-for-videos-or-other-non-standard-image-

    .

  • I see, I thing it is better either to convert the tiff to jpeg or find a plugin that can manage both the uploading and the conversion to jpeg like "ploader" ( for piwigo ).
    Thanks a lot.

    Best Regards.

    MyAGzenphoto

  • acrylian Administrator

    If your server suppports Imagick and that is setup to support tiffs you might be able to use them directly. But otherwise if using GD there is no way to convert tiffs as they cannot be processed.

  • Interesting, Imagick is installed on my server.
    How can I do to use it from the client browsers.

    Best Regards.

    MyAGzenphoto

  • acrylian Administrator

    If you have Imagick and it is properly configured, Zenphoto should offer a checkbox to use it on the options.

  • By the way, I though imagemagick was installed, after a checking I realised that it was not true.
    So, I just installed imagemagick now and how can I configure it to
    support tiffs ?

    Best Regards.

    MyAGzenphoto

  • acrylian Administrator

    You need the native php extension Imagick on your server, ImageMagick itself is not enough.

  • I understand that Imagick is not ImageMagick, it is different.
    How can I check this ?
    any way how to solve this problem ?

    Best Regards.

    MyAGzenphoto

  • acrylian Administrator
    edited October 2017

    Setup will tell you if Imagick is available or not. If there is also no optin to check it, it is also not there.

    As said it needs to be installed natively on your server. If it isn't best ask your host if that is possible.

Sign In or Register to comment.