strange behavior with site_upgrade

I use site_upgrade plugin when I do some maintenance.
I noticed something strange: when site is closed, the main link (domain_name) is redirected to site_upgrade page.

but for rewrited link, as domain_name/page/gallery, the redirected link is:

domain_name/page/gallery/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/plugins/site_upgrade/closed.php

and of course it is wrong and causes an error in my browser (FF).

you can see it in action here:

http://test.vincentbourganel.fr is redirected to http://test.vincentbourganel.fr/plugins/site_upgrade/closed.php
and with http://test.vincentbourganel.fr/page/contact there is a bad redirection.

the issue is not occured if site is in test mode.

Comments

Sign In or Register to comment.