Captcha + Comments

I am using Zenphopto with zenpage. Could you help me out with 2 issues:

1. the captcha image on the comment form looks tiny on my site. I would like to enlarge it, but cannot find the way to do it (CSS or other).

2. the comments do not appear on my image page, only the notice "1 comment published"

Thanks a lot in advance for your help.


  • What theme do you use ?

    I suppose you are talking about the Zenphoto captcha and not the reCaptcha from Google.

    # 1 : You have to create a entry in your CSS :

    `#commententry img {width: xx px;}` but i believe that the picture display will be blur.
    You can also change the captcha type in the security option.

    # 2 : I don't know, it's depend on the theme i believe.
  • Thank you, Laurent.

    As I wrote, I am using zenpage.

    I can create the CSS entry, but cannot find where to apply it. Where is the commentform?
  • acrylian Administrator, Developer
    #2: Check the settings of the comment form plugin. Also check if comments are enabled for the item in question.
  • #2: I checked the comment form plugin and the comments are enabled for the image page
  • acrylian Administrator, Developer
    Do you have the option "toggle comment block" enabled? Try disabling that. If it is enabled and does not provide any means to untoggle you probably have a Javascript error somewhere.
  • You must place the code in the CSS. The place does not matter ...
    I thought you meant the extension Zenpage not the theme ... sorry.

    For comments, you must also check if the images are to authorize and verify that the option "hide comments" is not checked.
  • Merci, Laurent !

    That was the problem. "hide comments" was checked. I thought a button would appear if I checked this, but apperently I have to put one myself.

    As regards the CSS, I have added the code to the style.css, but I have to add a tag pointing to this code somewhere and the question is where.
  • De rien ;)

    Normally this code shoud work. I try it on my test site.
    I put 200px widht in the css

    Here a example : ``
  • It works ! Merci encore !

    Can you please, tell me another secret? Where to find and enable the option "toggle comment block" acrylian is speaking of and that exists apparently opn your site? Is this possible with zenpage?
  • With Zenpage i believe you have to code a little bit the theme.
    My theme is a mix of different theme.
    Look at the Zpardoise theme i think it use this function.
  • Thanks a lot to both of you! I'll try it with Zpardoise.
  • acrylian Administrator, Developer
    @Soleil: The option is on the comment_form plugin options. It seems indeed that the Zenpage theme does not use it. Sorry, I thought it does.
Sign In or Register to comment.