![]() |
|
Can't update to 1.4.4.1b, error 500 - Printable Version +- ZenphotoCMS Forum (https://forum.zenphoto.org) +-- Forum: Support (https://forum.zenphoto.org/forum-1.html) +--- Forum: General support (https://forum.zenphoto.org/forum-4.html) +--- Thread: Can't update to 1.4.4.1b, error 500 (/thread-10807.html) |
Can't update to 1.4.4.1b, error 500 - Jaanus - 2013-02-02 Hi, in some unknown reasons I can't update to the 1.4.4.1b, neither. Have to revert to 1.4.4 back again. PHP: 5.3.21 MySQL: 5.5.28 Google Chrome shows me the following error (the same was aalso with initial 1.4.4.1 and 1.4.4.1a) : Server error The website encountered an error while retrieving http://my.site.xx/zp-core/setup/index.php?autorun=gallery. It may be down for maintenance or configured incorrectly. Here are some suggestions: Reload this webpage later. HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request. Can't update to 1.4.4.1b, error 500 - sbillard - 2013-02-02 Please examine your error logs and post the relevant error messages. Also please post a link to a PHP ini display of your site configuration. Can't update to 1.4.4.1b, error 500 - Jaanus - 2013-02-02 link to a PHP ini display of your site configuration That means? Can't update to 1.4.4.1b, error 500 - Jaanus - 2013-02-02 well, enabled displaying erross. When updated and pointed to my zp site: Fatal error: Cannot redeclare db_connect() (previously declared in /..../zp-core/functions-db-MySQLi.php:23) in /.../zp-core/functions-db-MySQL.php on line 51 Can't update to 1.4.4.1b, error 500 - sbillard - 2013-02-02 I wished to see the PHPini output to know what database software modules were installed in PHP. I am guessing that the database software that is set in the configuration file is not supported by your PHP installation. But that is just a guess. Also a guess, but if you edit the zenphoto.cfg file and set the database software item to 'MySQL' things will probably work. But that is only if the MySQL module is installed. Can't update to 1.4.4.1b, error 500 - Jaanus - 2013-02-02 Fixed it just for myself this way: in setup/index.php line 190 where is $preferences = array('mysqli'=>1,'pdo_mysql'=>2,'mysql'=>3); I switched the 1st and 3rd, so this line became $preferences = array('mysql'=>1,'pdo_mysql'=>2,'mysqli'=>3); EDIT: just after posting this I saw your reply. But I hope my post about occasional success is useful as well
Can't update to 1.4.4.1b, error 500 - Jaanus - 2013-02-02 MySQL Support enabled Active Persistent Links 2 Active Links 2 Client API version 5.5.28 MYSQL_MODULE_TYPE external MYSQL_SOCKET /tmp/mysql.sock MYSQL_INCLUDE -I/usr/local/mysql/include MYSQL_LIBS -L/usr/local/mysql/lib -lmysqlclient Directive Local Value Master Value mysql.allow_local_infile On On mysql.allow_persistent On On mysql.connect_timeout 60 60 mysql.default_host no value no value mysql.default_password no value no value mysql.default_port no value no value mysql.default_socket /tmp/mysql.sock /tmp/mysql.sock mysql.default_user no value no value mysql.max_links Unlimited Unlimited mysql.max_persistent Unlimited Unlimited mysql.trace_mode Off Off mysqli MysqlI Support enabled Client API library version 5.5.28 Active Persistent Links 0 Inactive Persistent Links 0 Active Links 0 Client API header version 5.5.28 MYSQLI_SOCKET /tmp/mysql.sock Directive Local Value Master Value mysqli.allow_local_infile On On mysqli.allow_persistent On On mysqli.default_host no value no value mysqli.default_port 3306 3306 mysqli.default_pw no value no value mysqli.default_socket no value no value mysqli.default_user no value no value mysqli.max_links Unlimited Unlimited mysqli.max_persistent Unlimited Unlimited mysqli.reconnect Off Off PDO PDO support enabled PDO drivers mysql, sqlite, sqlite2 pdo_mysql PDO Driver for MySQL enabled Client API version 5.5.28 Directive Local Value Master Value pdo_mysql.default_socket /tmp/mysql.sock /tmp/mysql.sock pdo_sqlite PDO Driver for SQLite 3.x enabled SQLite Library 3.7.7.1 Can't update to 1.4.4.1b, error 500 - sbillard - 2013-02-02 Not at all sure what happened here. You seem to have MySQLi enabled so that should have been the preferred database. (The original order of the preferences list.) Can't update to 1.4.4.1b, error 500 - Jaanus - 2013-02-03 But could MySQLi module be absent while MySQL module is present? I just see MYSQL_MODULE_TYPE but not MYSQLI_MODULE_TYPE Can't update to 1.4.4.1b, error 500 - sbillard - 2013-02-03 What I was reading was: ` mysqli MysqlI Support enabled Client API library version 5.5.28 Active Persistent Links 0 Inactive Persistent Links 0 Active Links 0 Client API header version 5.5.28 MYSQLI_SOCKET /tmp/mysql.sock ` So I would presume that the module is really there. But maybe there is some issue with it. Or maybe some other thing happened. It is certainly possible to have both modules present. The recommendation though, is to use MySQLi over MySQL when the former is present. The MySQL module will be eventually removed from PHP. |