![]() |
|
set_time_limit() error during backup - Printable Version +- ZenphotoCMS Forum (https://forum.zenphoto.org) +-- Forum: Support (https://forum.zenphoto.org/forum-1.html) +--- Forum: General support (https://forum.zenphoto.org/forum-4.html) +--- Thread: set_time_limit() error during backup (/thread-11515.html) |
set_time_limit() error during backup - mowgli597 - 2013-11-30 When performing a database backup the Debug log is flooded with the following message: "WARNING: set_time_limit() has been disabled for security reasons in /home/bpskdk/public_html/zenphoto/zp-core/utilities/backup_restore.php on line 49 set_time_limit called from extendExecution (backup_restore.php [49])" Zenphoto version 1.4.5.7 [59c22b2fba] (Official build) Current locale setting: en_US.UTF8 PHP version: 5.3.27 Graphics support: PHP GD library bundled (2.1.0 compatible) supporting: gif, jpg, jpeg, png, bmp PHP memory limit: 128M MySQLi version: 5.5.32 Spam filter: akismet CAPTCHA generator: zpCaptcha Mowgli set_time_limit() error during backup - sbillard - 2013-11-30 That is compliments of your hosting service. The database backup can run longer than the default script timer allows so Zenphoto extends the limit. Perfectly safe since the loop Zenphoto is in has a definite termination condition. But I guess your service provider "knows better" than the software so has disabled this PHP function. If the backup works you can ignore the messages. If the backup fails because it runs out of time you will need to complain to your host. set_time_limit() error during backup - mowgli597 - 2013-11-30 Thanks for the speedy response. Will take it up with the hosting company. |