![]() |
|
Permissions / Not saving theme options - Printable Version +- ZenphotoCMS Forum (https://forum.zenphoto.org) +-- Forum: Support (https://forum.zenphoto.org/forum-1.html) +--- Forum: General support (https://forum.zenphoto.org/forum-4.html) +--- Thread: Permissions / Not saving theme options (/thread-12128.html) |
Permissions / Not saving theme options - ditz929 - 2014-09-13 I just installed zenphoto so still learning my way around. Here is my install: Zenphoto version 1.4.6 [bbddab7675] (Official build) WEB path: www.themoehrings.com/gallery Current gallery theme: Basic PHP version: 5.3.27 Graphics support: PHP GD library bundled (2.1.0 compatible) supporting: gif, jpg, jpeg, png, bmp PHP memory limit: 128M (Note: Your server might allocate less!) MySQLi version: 5.5.15 The setup files were not able to create the .htaccess or robots file and I had to manually change permissions and add folders. So it seems like there may be a permissions problem. I got through setup finally, but cannot save any theme options. The page says they were saved, but it reverts to default. Also, if I try to change the theme, the thumbnails no longer work. Any ideas? Permissions / Not saving theme options - fretzl - 2014-09-13 First thing to do is to look in your Debug log. Admin -> Logs (tab) Also, if your server does not support mod_rewrite (that's why a .htacces file is not created) make sure the mod_rewrite checkbox is not checked. Admin -> Options -> General -> URL options -> mod rewrite [EDIT] Some info about permissions: http://www.zenphoto.org/news/permissions-for-zenphoto-files-and-folders Permissions / Not saving theme options - ditz929 - 2014-09-14 Thanks for the reply. I have mod rewrite turned off. I tried a fresh install at www.themoehrings.com/zp/ It still doesn't save theme options. Are those stored in the db or in a special file that I should check the permissions on? Thanks again. Permissions / Not saving theme options - fretzl - 2014-09-15 Looks like you are on a Windows server. Have had similar problems on a Windows server too. Turned out the host had way too many security restrictions configured. Try contacting your host. Permissions / Not saving theme options - ditz929 - 2014-09-15 Everything is working except for the theme options. I'm able to change all other settings. . . when I attempt to change them, it says changes were applied, but it doesn't change. So I don't get any errors. Permissions / Not saving theme options - acrylian - 2014-09-16 Did you look into the server error log? That might have errors the Zenphoto own log doesn't. |