![]() |
|
PHP security vulnerabilities - Printable Version +- ZenphotoCMS Forum (https://forum.zenphoto.org) +-- Forum: Support (https://forum.zenphoto.org/forum-1.html) +--- Forum: General support (https://forum.zenphoto.org/forum-4.html) +--- Thread: PHP security vulnerabilities (/thread-14184.html) |
PHP security vulnerabilities - ctdlg - 2026-10-22 My Zenphoto site is running on PHP 8.4.26. RE: PHP security vulnerabilities - acrylian - 2026-10-22 Zenphoto 1.6.8 should work generally with 8.5 already but there might be some notices here and there. There are fixes for all supported versions:
So it is probably only a matter of time your host will also apply those. RE: PHP security vulnerabilities - MarkRH - 2026-10-23 Heh.. my galleries (v1.5.7) are running on PHP version 7.4.33. Luckily my webhost backported the patch to that version. My other sites are on PHP 8.1.34 which was also patched. My webhost did remove PHP versions 7.2 and 7.3 from their shared servers. In my case they patched PHP without actually changing the version numbers. I need to work on getting everything to PHP 8.2.X at some point. RE: PHP security vulnerabilities - acrylian - 2026-10-23 Zenphoto 1.5.7 is of course very outdated. Just to mention it again ;-) Yes, most hosts even provided patches to PHP versions that are not officially supported anymore. You should not get to PHP 8.2 because its support ends in about two months. I strongely recommend to update your Zenphoto and switch to 8.4 instead. RE: PHP security vulnerabilities - ctdlg - 2026-10-24 Thanks. Two hours after asking my question here, php patches were applied by my webhost. |