Your string is correct, so it should not throw the error. I did make a change in the support build to detect an invalid http accept language string and ignore it. That would presumably fix the problem, but as I said, the above string is correct, so it is really unclear what caused the error.
Since these errors are in your logs, it may be a flawed browser (or hacker) that is accessing your site. At any case, install the support build and let us know if the error reoccurs.