Member
Member
bioenergy   2013-11-05, 16:18
#1
A corrupt configuration file was detected. You should remove or repair the file and re-run setup.

How to Fix

//////////////////////////////////////////////////////////////////////////////// $conf['special_pages'] = array( 'page'=> array('define'=>'_PAGE_', 'rewrite'=>'page'), 'search'=> array('define'=>'_SEARCH_', 'rewrite'=>'page/search'), 'archive'=> array('define'=>'_ARCHIVE_', 'rewrite'=>'page/archive'), 'tags'=> array('define'=>'_TAGS_', 'rewrite'=>'page/search/tags'), 'news'=> array('define'=>'_NEWS_', 'rewrite'=>'news'), 'category'=> array('define'=>'_CATEGORY_', 'rewrite'=>'news/category'), 'news_archive'=>array('define'=>'_NEWS_ARCHIVE_', 'rewrite'=>'news/archive'), 'pages'=> array('define'=>'_PAGES_', 'rewrite'=>'pages') ); /////

MY Site :
www.katalogsales.com
Member
Member
bioenergy   2013-11-05, 16:31
#2
Admin Are you here??
Chould Teach me how to fix the issue on my site???
How TO Re-Run Setup???
Member
Member
sbillard   2013-11-05, 17:24
#3
http://www.zenphoto.org/news/installation-and-upgrading#re-running-and-re-uploading-setup-files
Member
Member
flu   2013-11-05, 17:24
#4
Hi,
just log as admin to your website then in the "overview" tab, you have a link to restaure the setup scripts, then go to www.yourwebsite/zp-core/setup.php and re-run setup.
Before all that, make a database backup.

Edit : Sbillard was highly quicker.
Member
Member
bioenergy   2013-11-05, 17:31
#5
i type :
www.katalogsales.com/zp-core/setup.php

Aslo same Issue Happen.

What File Should I removed What File Should i repair??
Member
Member
sbillard   2013-11-05, 17:40
#6
you must remove the configuration file: `.../zp-data/zenphoto.cfg.php`
Member
Member
bioenergy   2013-11-05, 18:04
#7
Thank Admin Issue Soft
Member
Member
Panda   2014-03-14, 16:33
#8
Hi, I am having the same issue now. As i open my site, the error message "A corrupt configuration file was detected. You should remove or repair the file and re-run setup."
I have added and I can not get to the screen to re-run.

Your advice would be appreciated.
Administrator
Administrator
fretzl   2014-03-14, 17:30
#9
What did you do exactly ?
Administrator
Administrator
acrylian   2014-03-14, 17:30
#10
Create a new config file manually (template is in zp-core) and review the error log for furhter related errors (permissions especially)
Member
Member
Panda   2014-03-14, 18:07
#11
thanks for the replies guys,

the problem has been solved! ( I did not & someone else did though :-P)

@fretzi: what I did exactly is that I tried to get to the "overview" page by adding zp-core/setup.php at the end. A blank page appeared and I could not do anything.

@acryllan: A pro has solved the problem :-) and he told me that I have not upgraded to the
latest version of Zenphoto. I will read up this forum more.
Member
Member
n20capri2   2014-03-28, 22:34
#12
This keeps happening to my sites as well. I have several ZP installs...Most are the latest version. This isn't happening during an upgrade either...the config file is just randomly coming up corrupt...

I have a copy of all my config files and all I have to do is delete the old and re-upload it and all is well but I can't figure out why it keeps happening. Nothing unusual in the log files either...
Administrator
Administrator
acrylian   2014-03-28, 22:38
#13
I have several sites (with various even older versions - upgrade unwilling site owners, you know them Wink and this never happened to me anywhere yet.

Maybe some changes on the server by the host that affect file/folder permissions or something?

If you look at those corrupt files what do they look like, what actually is corrupt?
Member
Member
sbillard   2014-03-30, 01:22
#14
I believe this is caused by a hack. You should be sure you are on the 1.4.5.9 release AND that you have protected your setup scripts.
  
Powered By MyBB, © 2002-2026 MyBB Group.
Made with by Curves UI.