First error is not an error, that's the mod_rewrite URL structure. Perfectly normal.
Second error, you're technically not allowed to view a folder in a web server, hence the error. That also is perfectly normal.
The problem is that your server does not have mod_rewrite turned on. You'll need to disable it in Zenphoto, or ask your host to enable mod_rewrite on for your server. To turn it off in zenphoto, make the $conf['mod_rewrite'] line like this:
`$conf['mod_rewrite'] = false;`