Member
Member
wearwolfie   2017-12-31, 10:08
#1
Hi there...
My Zenphoto site has started throwing the following error...

Fatal error: MySQLi Error: ( SELECT * FROM `[prefix]news` WHERE `date`<="2017-12-31 08:59:49" AND `show`="1" AND `expiredate`<="2017-12-31 08:59:49" AND `expiredate`!="0000-00-00 00:00:00" AND `expiredate` IS NOT NULL ) failed. MySQLi returned the error MySQL server has gone away in /mounted-storage/home117a/sub005/sc62105-HHGW/www/mywebsitename/zp-core/functions-db-MySQLi.php on line 78

I get similar when trying to login to admin.

When i go to mywebsite/zp-core/setup.php I get the message

You must restore the setup files from the 1.4.12 [c1d7e8900b] release.

What may be the cause and how do I do this?
Many thanks
Mark
Administrator
Administrator
acrylian   2017-12-31, 10:44
#2
The error means that your database server is not resonding correctly or Zenphoto is not configured correctly.
Why that might be I cannot answer. I suggest to contact your host about this issue as it might be caused by a server configuration change.

In any case also check your Zenphoto config file in `/zp-data/zenphoto.cfg.php` that it really has the correct database credentials. If unsure contact also your host.

I modified your discussion title as this is not related to accessing previous versions (this version is available for download on GitHub in any case).

Regarding the restoring of setup files please see here:
http://www.zenphoto.org/news/installation-and-upgrading/#re-running-and-re-uploading-setup-files
This all will of course not work if MySQL is not working correctly.

Member
Member
wearwolfie   2018-01-03, 15:29
#3
Thank-you for the prompt reply. Re-ran the setup and it's all sorted. Thank-you
  
Powered By MyBB, © 2002-2026 MyBB Group.
Made with by Curves UI.