If you have a fresh install without any config file or any database respectively without tables setup will run automatically actually.
If it is an existing install it will not, not even when teh database credentials are wrong, missing. It would be quite bad to expose that to the outside other than on fresh installs.
If you reached the licence agreement you must have passed setup. It consists on two pages you cannot miss actually. Take a look here:
https://www.zenphoto.org/screenshots/setup/setup-page1-systemcheck.jpg.html (these are not the very current version but generally the same still).
You can run setup by accessing yoursite-install-path/zp-core/setup/. On existing installs you need to be login with admin rights and may have to enable setup files again.
> The show Gallery click showed a blank page.
When ever you get a blank page review your server error log as that usual means a PHP fatal error that can be caused by numerous things.