Member
Member
steve mcmillen   2010-02-23, 21:43
#1
So I'm getting this error in one of my galleries..

Zenphoto Error
MySQL Query ( INSERT INTO `zp_obj_to_tag`(`objectid`, `tagid`, `type`) VALUES (300,,'images') ) failed. Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''images')' at line 1

Any idea?
Member
Member
sbillard   2010-02-23, 22:28
#2
Check your database. The `tags` table should have a field named `id` which is set to autoincrement. I'm guessing it is not set to autoincrement.
Member
Member
steve mcmillen   2010-02-23, 23:01
#3
Thanks for the quick response. I did check the mysql table and it id field is set properly to autoincrement. Could the issue be caused by a bad image file or non supported version of a jpeg or png?
Member
Member
sbillard   2010-02-23, 23:50
#4
I doubt it. The ID field from a query came back empty. That cannot happen with autoincrement. Maybe there is a record with an empty ID?
  
Powered By MyBB, © 2002-2026 MyBB Group.
Made with by Curves UI.