I just had the very same error, and was looking for how to fix it too!
The default .htaccess file should be residing in bazalicious.com/gallery
my issue was extra text below the </IfModule> line at the end. I had "Options All -Indexes" and "Options All" down there, I believe they are put there by cPanel is you do things to hide directories.
I have just tried to access http://gallery.bazalicious.com/ and the domain could not be resolved. Have you actually set it up yet in your hosting provider's control panel?