Member
Member
RFick   2009-01-06, 03:02
#1
Yes, I know this has been an issue in the past and I see others have posted, they did a few things or were told use a different release and it worked for them, well, that's not me.

I am also having the same issue they did, tried their tricks and got no where. =(

I have installed the latest nightly build: zenphoto-2009-01-04-trunk.zip

I have verified that in PHP.ini I have "short_open_tag = On" it WAS off

I see no error in my apache logs, just this entry in access.log (which looks normal?):
127.0.0.1 - - [05/Jan/2009:17:46:31 -0800] "GET /test/zp-core/setup.php HTTP/1.1" 200 -

If I try other php files in the install dir I do get an error:
Fatal error: Call to undefined function gettext() in C:\Inetpub\wwwroot\Ryan.FickFamily.ca\test\zp-core\functions-db.php on line 30

I do get output from my phpinfo.php file I placed in the dir.

OS = WinXP
apache 2.2.11
mysql 5.2.6
mysql 5.1.30
Member
Member
RFick   2009-01-09, 00:15
#2
Can nobody think of anything to help me?
Member
Member
sbillard   2009-01-09, 02:58
#3
Blank pages are almost always caused by PHP script errors. If you do a `view source` from your browser what shows up?

Is `http://ryan.fickfamily.ca/test/zp-core/setup.php` the correct URL? If I visit that it is showing a [i]500 Internal Server Error[/i] so it would seem there is a problem with your server setup.
Member
Member
RFick   2009-01-09, 17:21
#4
Yes, that is the right url for the page currently.

I do not even GET any thing back, it's totally blank, looking at the source also shows up blank.

Odd that you got a 500 error, can you see the phpinfo.php file okay? I can so that leads me to wonder just what part of my setup is wrong?

http://ryan.fickfamily.ca/test/phpinfo.php
Member
Member
RFick   2009-01-09, 17:57
#5
It LOOKS like I just hadn't installed MySQL properly for PHP.

I re-installed PHP and found a hidden little add-ons section and this time I included MySQL. I restarted Apache, and whalla. I can see the setup page now.

Next step is fixing the error about GP for PHP & the other warnings. I'll see what I can do to clear those up. I'll post here if I get um fixed.

----------------------------->8 SNIP 8<-----------------------------------
PHP GD support is not installed
Error!

You need to install GD support in your PHP

PHP gettext() support [is not present]
Warning!

Localization of Zenphoto currently requires native PHP gettext() support

PHP setlocale() failed
Warning!

Locale functionality is not implemented on your platform or the specified locale does not exist. Language translation may not work.
See the troubleshooting guide on zenphoto.org for details.
Member
Member
RFick   2009-01-09, 18:41
#6
Fixed 2 of the issues with yet another re-install of PHP and finding GD2 & gettext and turning those on.

PHP GD support
PHP gettext() support

Now just onto "PHP setlocale() failed"
Member
Member
RFick   2009-01-09, 19:08
#7
Seems the newer nightly build stops at that last warning and gives nothing after that. I went back to using 1.2.2 and I get much more now.

Next setp is to fix the mysql database errors etc.
Member
Member
RFick   2009-01-09, 19:47
#8
Okay, gotten rid of all the errors.
Now just a few errors.

One that concerns me follows, as you can see, I gave it all the access it needs.

Your MySQL user must have Alter, Create, Delete, Drop, Index, Insert, Select and Update rights.

Grants found:

GRANT USAGE ON *.* TO 'ZenPhoto'@'%' IDENTIFIED BY PASSWORD xxx
GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX, ALTER ON `zenphoto`.* TO 'ZenPhoto'@'%'
Member
Member
RFick   2009-01-09, 20:03
#9
Okay, all issues I have had other than warnings have been cleared up.

I thank you for your help & support.

I will next be posting about some other topics.
IE. Usage etc...
  
Powered By MyBB, © 2002-2026 MyBB Group.
Made with by Curves UI.