It's either that, or zenphoto is having trouble processing so many images.
I'm using zenphoto version 1.2.4 [3716] in conjunction with a trendnet TV-IP212W wireless network camera that connects to a linksys WRT54GL wireless router (which connects to the internet via cable). When the camera detects motion, it takes a picture, then connects to an online server and uses FTP to upload the photo to the "albums" folder of zenphoto (in a secondary folder the represents the day the photo was taken, ex: "20090417").
It averages between 500-800 motion detected picture uploads per day, and it appears if I don't take a look for a few days it tends to give me the "exif" errors. If I continue to refresh it eventually works.
I guess another work around is a way to automatically cache images at a regular interval, without a user having to load the page, or admin pre-caching.
Any tips on how to do this (I'm guessing a cron job, but I'm not too familiar with those)?