The warnings can, of course, be ignored. The error is caused by some kind of file permissions problem with the zp-data folder. You will probably need to correct this as that folder is used for other zenpoto files besides the zp-config.php one.
But if you cannot fix the file permissions, you will need to do as the error message suggests and create the zp-config.php file manually.