I cannot find this information in your troubleshooting. And these warning messages I do not know how to resolve, can you assist?
You should consider disabling magic_quotes_gpc. For more information See What is magic_quotes_gpc and why should it be disabled? in the Zenphoto troubleshooting guide.
Warning!
Setting mbstring.internal_encoding to UTF-8 in your php.ini file is recommended to insure accented and multi-byte characters function properly.
Warning!
If file and folder permissions are not set to strict or tighter there could be a security risk. However, on some servers Zenphoto does not function correctly with tight file/folder permissions. If Zenphoto has permission errors, run setup again and select a more relaxed permission.
Change file/folder permissions mask: strict+ (0750) strict (0755) relaxed (0775) loose (0777)
There is nothing in my MYSQL about this issue above.
MySQL setup in zp-config.php
Error!
Access denied for user: 'mysiteuser@localhost' (Using password: NO)
I set a password, but perhaps not in the right place?