Unfortunately, there is no way we can answer your question. Ideally you would set "strict" permissions and all would be fine. But, depending on the mis-configurations of a particular server this may not work.
You can try with "loose" permissions and see if that will work. If so, tighten them up until it no longer works. Beyond that you will have to work with your provider to understand what is the root cause of the 500 error.