Member
Member
john_of_the_tower   2011-01-29, 00:17
#1
Hi all
I'm brand new here, trying my first installation of ZP.
Alas, looks like there is a problem : when I try to publish an album, this message appear : La requête MySQL ( SELECT * FROM `zp_images` WHERE `albumid`= ) a échoué. Erreur : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1
Any solution ?
Member
Member
sbillard   2011-01-29, 00:42
#2
If you have not already done so, please install the 1.4.0.1 release of Zenphoto.

Then if you still have this problem please find the following line in `globsl-functions.php`:
`define('DEBUG_ERROR', !defined('RELEASE')); // set to true to supplies the calling sequence with zp_error messages`

change it to read:
`define('DEBUG_ERROR', true);`

This will provide a bit more information on the above error. Please post the result.
Member
Member
john_of_the_tower   2011-01-29, 01:58
#3
thanks for your answer. WHere thait file is supposed to be ? Even after a search in the zen root folder I cannot find it.
Member
Member
sbillard   2011-01-29, 02:07
#4
there is a typographical error. The name is `global-functions.php` (Really supprised that you could not recognize that. If you have not installed 1.4.0.1 then the file might not be present.)
Member
Member
john_of_the_tower   2011-01-29, 02:09
#5
I did install 1.4.0.1 and did it twice to be sure. And stille I cannot find that file
Member
Member
john_of_the_tower   2011-01-29, 02:15
#6
is that global definitions ?
Member
Member
john_of_the_tower   2011-01-29, 02:18
#7
got it that was that : global-definition.php
Apparently, two values are set on !defined('RELEASE')
Member
Member
john_of_the_tower   2011-01-29, 02:22
#8
I changed the values to what you said to me. It is still not working (cant publish y page or image and I've got thoses error messages).
Thanks for ansering : I'm just lost !

Notice: Zenphoto a produit une erreur 404 sur /test/www.johnofthetower.com. Voir le fichier log de debug pour plus de détails. in /homez.406/johnofth/www/zp-core/functions.php on line 2097

Warning: Cannot modify header information - headers already sent by (output started at /homez.406/johnofth/www/zp-core/zp-extensions/static_html_cache.php:229) in /homez.406/johnofth/www/index.php on line 179

Warning: Cannot modify header information - headers already sent by (output started at /homez.406/johnofth/www/zp-core/zp-extensions/static_html_cache.php:229) in /homez.406/johnofth/www/index.php on line 180
Member
Member
john_of_the_tower   2011-01-29, 02:27
#9
Could it be linked to magic quote which is running ?
Administrator
Administrator
acrylian   2011-01-29, 11:23
#10
Yes, it is recommend to turn it off.
Member
Member
sbillard   2011-01-29, 21:18
#11
These new 404 errors are different from the SQL one you originally posted. So, I presume that has gone away with the 1.4.0.1 release.

404 errors are caused by referencing a page not found by Zenphoto. The debug log will have more details of what was referenced. But a likely cause is that mod_rewrite is not working correctly.
Member
Member
michaeldt   2011-02-02, 01:54
#12
I have a similar error to the above. I find that when trying to apply changes to the included themes, i get this error.

I'm using the current (as of 01/02/11) version. If I goto themes and then on a particular theme, click "Set [themename] theme options", and then try to apply changes, i get the following error:

Zenphoto encountered an error
MySQL Query ( SELECT `name`, `value`, `id` FROM `zp_options` WHERE `name`='Allow_search' AND `ownerid`= AND `theme`='default' ) failed. MySQL returned the error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND `theme`='default'' at line 1
Backtrace:

-> query (functions-db-MySQL.php [90])
-> query_single_row (functions.php [1937])
-> setThemeOption (admin-functions.php [857])
-> processCustomOptionSave (admin-options.php [414])

However, if I activate a theme and then edit it's options by clicking "options" then "themes", I can apply changes successfully.
Member
Member
sbillard   2011-02-02, 19:18
#13
Please explain what you mean by current (as from 01/02/11) release as there is currently version 1.4.0.1 released 1/22/2011.
Member
Member
michaeldt   2011-02-03, 01:57
#14
Sorry, current as in 1.4.0.1.
Member
Member
sbillard   2011-02-03, 05:02
#15
You should try the nightly build then. I am sure we had such a problem and it has been fixed.
  
Powered By MyBB, © 2002-2026 MyBB Group.
Made with by Curves UI.