Problem running a "new" gallery on XAMPP


I'm trying to run Zenphoto locally so I'll be able to finetune my theme.

Online, I successfully run:
Zenphoto v 1.4.3 [10423 - official)]
Apache 2.2.21
PHP : 5.2.17 (with GD library 2.0.34 compatible
MySql: 5.1.62

Locally, I try to run the same version of Zenphoto, on XAMP with the latest XAMP (1.8.0) which has:
Apache 2.4.2
PHP : 5.4.4 (with GD library)
MySQL: 5.5

I'm trying with
$conf['mysql_user'] = 'root' and 'gagnon';
$conf['mysql_pass'] = '' and 'passwordForGagnon';
$conf['mysql_host'] = 'localhost';
$conf['mysql_database'] = 'zpmg';
The setup begins; after I press Go, the process stalls indefinitely with the message "About to create tables"

Any "Windows specialist" that might have clues to make it work? I remember I ran it on a local server a long time ago, but I don't remember what settings I used, or if something significant changed in Zenphoto.


Other interesting notes:

1. Here is the MySQL log file:
Version: '5.5.25a' socket: '' port: 3306 MySQL Community Server (GPL)
120714 23:24:08 [Warning] Invalid (old?) table or database name '#sql2-11dc-42'
120714 23:24:09 [Warning] Invalid (old?) table or database name '#sql2-11dc-42'
120714 23:24:09 [Warning] Invalid (old?) table or database name '#sql2-11dc-42'
120714 23:24:09 [Warning] Invalid (old?) table or database name '#sql2-11dc-42'
2. When I use phpMyAdmin to look into the database
– it has all 16 tables, but with no data yet (things seem to freeze at that point)
– "Type" of tables is innoDB
(on the database of the online working setup, it's MyISAM)

A description of this "new feature" of MySQL is found here:



Is the bug I have simply related to the change in MySQL engine, or do I need to change my configuration parameters or use an older version of XAMPP or...?



  • fretzl Administrator
    Currently there is a ticket for something similar on a Windows IIS server.
    Maybe you can check the following:
    In zp-core -> setup -> setup-option-defaults.php comment line 13 that reads: `require_once(dirname(dirname(__FILE__)).'/'.PLUGIN_FOLDER.'/security-logger.php');`
    and see if setup takes you one step further.
  • acrylian Administrator
    I sadly cannot help since I am on Mac using MAMP. There the db user /password is always "root" and cannot even be changed (I never tried since its locally).

    Sbillard is on Windows as well but I think he uses WAMP.
  • I do indeed use WAMP, not XAMP. I think I tried XAMP one time but it did not seem to have any particular benefits.

    There should be an apache log and/or a PHP log that you can look for reported errors.

    I too get those "old table" errors, but nowhere do I see the tables mentioned. I suspect this is a bug in MySQL.
  • Thanks to the three of you.
    As I found ways to make it work, I have analyzed a bit the situation, so it may help you to solve the problems that can be solved.

    I tried WAMP to see if there are any differences. Once I configured it successfully, I got to the same problem: system stalls at "About to create tables"... I also got the same behaviour with both servers, so my comments down here equally apply to both XAMPP and WAMP.

    I then tried Fretzl's solution and it works, both on WAMP and on XAMPP. Still wondering what happens, I decided to dig into "security-logger.php" to see where is the problem.

    Turns out that setup works to a point if I comment out line 33 of the "security-logger.php" file:

    So maybe something could be done there and it would solve the Windows IIs problem Fretzl was talking about.


    A second interesting problem is that once the setup is complete, I get the warning:
    "NOTE: We strongly recommend you remove the setup scripts from your zp-core folder at this time. You can always re-upload them should you find you need them again in the future." But there is no "Delete setup files" button.

    Process seems to stall at line 2368 of setup.php at:
    if (zpFunctions::hasPrimaryScripts())...

    If I remove the function from the IF (if (0 == 0), it's OK.


    Two other bugs:
    One is mind-buggling but minor: when present, the plugin "cloneZenphoto" prevents all plugins further down from being loaded. I.e. the list of plugins starts at "a" and stops at "class-WEBdocs". Once I completely removed "cloneZenphoto" (file and folder) from zp-extensions folders, it worked.

    One is a bit more stressful: only one theme is loaded. The Setup log tells me that the theme default options for all of them have been set, but the "Themes" administrative tab shows only the FIRST theme (default). If I remove it, then it becomes Effervescence plus and so on...

    So there must be an improperly initialized variable... either in Zenphoto or on my server.
    (Back 1 or 2 years ago, when I had successfully installed Zenphoto on XAMPP, I think I saw all themes.)


    A final problem is that mod_rewrite doesn't seem to work properly.

    With mod_rewrite ON, I can visit only the main page, but not subalbums and images. For instance, from http://mg.localhost/photos/, when I click on the first album, it says:

    The Zenphoto object you are requesting cannot be found:
    album: g.localhost/photos/essaiphotos
    (the path displayed seems good,
    except for the missing "m" at the beginning)

    P.S. One advantage I find with XAMPP over WAMP is that it is also available in a portable version, so I can develop the same installation – with databases – on different machines if necessary.
  • What version of Windows are you running?
  • At home, XP – SP3
  • Thanks, this is probably the same issue we are seeing in fretzl's ticket. Maybe you can join up with that
  • I did so a few seconds ago.

  • Exactly the same symptoms on Denwer running WinXP SP3
  • Read the ticket above.

    Short answer. Especially if it's for development at home (i.e. not a public interface where security could be an issue), download the nightly development version here:

    I'm not sure of yesterday's version, but tonight's version (2012-07-20-development) DOES work on XAMPP and WAMP and therefore should work on Denwer (from what I read – no experience with it).

    Anyway, tell us how it works!
Sign In or Register to comment.