Non admin users cannot access zp-core/admin-edit.php

Hi all,
I have what I think is a user/permissions problem. I currently trying to create a site for an Arts Foundation that will allow multiple users to have a primary top level album. When I initially create a user and give them upload/edit rights to their album everything seems to work OK. Once I log out and try to log back in to test a non admin user the upload process appears to work OK but after I click upload, instead of moving to the images section I get an error message stating that I haven't permission to acces zp-core/admin-edit.php. The admin toolbox only lists Overview and Logout as options. The images are uploaded and I can edit them normally with an admin account.
The site is hosted with 1and1, I'm using 1.4.3 but I have also tried installing a number of nightly builds and the problem persists. I am using a custom theme which is a duplicate of the zenpages theme. I have tried switching to the default zenpages them and there is no change.
I have tried different permissions settings during install/upgrade, again this seems to have no effect.
Help please as the site is due to go live soon.


  • acrylian Administrator
    What kind of permissions error you get if you access the page? A file/folder permissions error or a backend error about no rights to access that? If the first you might need to check the permissions of the files via FTP and possibly correct them. On some servers setup cannot do that. If the 2nd the users you create don't have upload rights possibly
  • Hi acrylian
    The error is a backend rights access error.
    I've checked permissions via FTP and the zp-core directory is 755 and the admin-edit.php file is 664.
    Here is a link to a jpg screen grab of a typical users rights setup:

    thanks for taking the time to answer my post

  • Try using the user groups plugin and set the user to be a member of the album managers.
  • Hi sbillard,
    thanks for taking a look.
    enabling the user groups plugin resulted in the following:

    Users created under the album managers template with a primary album generated the linked error (no access admin-edit.php) after images were uploaded.

    Also whilst logged in under an album manager user my home page (zenpage) and gallery page gave me the following password protection error.
    All other pages are viewable by these users including 1 other additional zenpage created page. The Admin Toolbox disappears while viewing those 2 pages also.

    These errors do not appear with any users with 'admin' privileges.

    Also since my previous post I have completely re-installed zp and created a new mysql db, just in case, without success unfortunately.

  • Hi all,
    I have noticed an odd sequence that may be relevant.
    I have disabled the user-group plugin and deleted all non admin users and their albums. Back to square one essentially.

    If I create one new primary album user with upload/edit privileges (lets call them user01) I can log in/out with any user (admin or not) and this user will behave as expected.

    If I create a second user (user02) I can log in with that user, upload and edit albums and images as normal. If I try to log back in with user01, I can no longer access zp-core/admin-edit.php and have no album options in tabs or toolbox.

    If I create a third user (user03) I then have no access through users 01 and 02.

    Effectively only the last created user has sufficient permissions to access admin-edit.php.

    Hope this information is of use.

  • Fix is in tonight's nightly build. Thanks for that last bit of information. It was what was needed to reproduce the problem.
  • Hi,
    just posting to confirm that has worked. Thank you so much for your help.

Sign In or Register to comment.