Sitemap images not indexed

I'm still having problems with the sitemap being indexed by Google. I added it throught webmaster tools. First a half year long with the .php extension, but that didn't help. Now I disabled the .php extension after the image name for about three months, but still no changes. Somehow the indexing stops after the albums:

http://ompldr.org/vZjFoZQ/Selectie_001.bmp
«1

Comments

  • acrylian Administrator
    Sorry, I don't use the google webmaster tools right now. If there is no error or any other message why it does that we are just guessing. Maybe there are limits or something?
  • Perhaps the sitemap is wrong for images to be indexed. The album pages etc. are pages, but for images I find this information from Google:
    http://support.google.com/webmasters/bin/answer.py?hl=en&answer=178636

    So perhaps the building of the sitemaps should go in two steps: one for pages/albums/indexes and one for the single images.
  • acrylian Administrator
    We actually have that built (the Google image extension). However made the `` part refer to the album page with the thumbs (that part was actually a contribution by a user we just took over). The image points to the cached sized image. Actually Google should be able to follow the links on the site itself as well. Or site is quite good indexed and we don't use the sitemap at all.

    Maybe we need a separate subsitemap with the image pages itself. But it might also be that Google does not like the urls to the image processor which will occur certainly if the images are not cached alredy. I think Googles feedreader has also problems with the RSS feed urls. I have also no idea why.

    So as always feel free to file a ticket for 1.4.4.
  • I checked the google image extension and then I get this kind of links in the sitemap.xml:

    http://www.jacktummers.nl/collectie/zp-core/i.php?a=beeldbank/zeeenstrand&i=wissant-250809-092.jpg&s=680&cw=&ch=&q=70&wmk=!

    Doesn't look like an easy link for Google to index an image.
    I just added the sitemap again to the google webmaster tools and it gives me a few warnings. One about a missing xml tag and the other about not being able to index the above url's, because I blocked the /zp-core directory in my robots.txt file.

    I'm just thinking this over, before adding a new ticket ;).
  • the i.php link will go away if the image is cached. So maybe pre-loading the cache before generating the site map would be a good idea.
  • acrylian Administrator
    The sitemap uses the default image sizes for sized images and thumbs, it does not know about any specific theme sizes (or custom theme structure). So running the cache manager for those hopefully should fix the issue.
  • Seems Google don't like parameter to display image, so it only record the file name like i.php or in my case full-image.php

    Ref: http://postimage.org/image/tb7ye5b9v/

    Not good for SEO... :(
  • acrylian Administrator
    As my colleague said above you need to make sure that the images are cached when generating the sitemap. If they are not you of course get the i.php image generator links. There is no way around. Btw, if you site is correctly done Google & Co should be able to follow the structure of the site even without the sitemap.

    If you get a full-image.php in the full image link you have set it to protected view. Then it is for that reason shown via as script and not directly.
  • I'm still strugling with the sitemap :)
    Albums are indexed by Google, images are not, but the don't appear in the sitemap files either so it isn't generated.

    The first screenshot here is of the error message Google gives for each of the images.xml files, the second one shows the ftp-folder of the cache, the third one is an empty xml file.

    http://ompldr.org/vZjk1cw/Selectie_030.bmp (missing xml-code)
    http://ompldr.org/vZjk2Mw/Selectie_031.bmp
    http://ompldr.org/vZjk2NQ/Selectie_032.bmp
  • Check to be sure your images are published.
  • Anyone any new ideas about the sitemap that is not functioning for me? Still no images indexed by google, still the same error message alerts by google. I have my messages cached, at least, the thumbnails, because the large images are the same size as used on the site. Like described on this page: http://www.zenphoto.org/news/how-does-zenphoto-cache-

    'However if your images uploaded are the same size as used for the single sized image they will not be generated.'
  • acrylian Administrator
    That is actually not even true anymore. THere are always cached images generated even if the same size as the originals. The reason is that checking via the filesystem everytime is more overhead than just creating such an image.

    I have updated the entry.
  • acrylian Administrator
    Sorry, I have no idea, but we don't even use the sitemap ourselves on zenphoto,org and loads of images are indexed nevertheless. Maybe try without, too?
  • I'll try it without then perhaps, although I'd really like to have a sitemap that is working ok. Could you not just test it once and see if the sitemap is generated ok with the google image extensions enabled?

    How come my images are not cached then? I don't want them to be cached (because they are the right size already) but if this is the only way to get them indexed by Google, I will cache them. But how? Now only the thumbs are cached.

    I'm using this code right now:

    `

    `
  • acrylian Administrator
    If you don't call custom sized/default size images on your theme's image.php but the the full images dircetly they will of course not be cached as they are not requested (remember the lazy load principle of Zenphoto). But even then the sitemap would call the image processor and create them. But of course if google has the problem with these urls probably even one of theme breaks it for all. So you need to use the cache manager to create the images or let google index it without a sitemap. A sitemap is by no means necessarily mandatory to get a site's images indexed.

    Our images are already indexed so I see no way how to do this again, besides I don't have an Google webmaster account for our site at all to check it.
  • OK, I now use printdefaultimage in image.php, but now have to make sure all the images are cached. So I added the cachemanager again, but this only shows the admin thumb images when I hit 'cache images':

    Refreshing cache for Galerij
    Toepassen admin_40_cw40_ch40_thumb

    I don't know how I can make it to precache all images.
  • acrylian Administrator
    You need to define what it should cache on its options. Note that you have to add some options to your theme options if you use any specific theme based image sizes (maxspace one for example).
  • As far as I understand, I don't use anu theme based image sizes. My images are the same size I upload them and I use printdefaultimage() on image.php. But I have no idea what to do with these options:

    http://ompldr.org/vZmNvZw/Selectie_025.bmp

    Whatever I fill in in the bottom part, when I hit save, nothing is saved.
  • Ok, then we ask the usual question: what is showing up in your PHP error logs?
  • The error logs within ZP say nothing about this.
    I tried to modify the first entry in the cache settings (admin), but no modifications are saved.
  • acrylian Administrator
    We mean of course as well the php error log. The zp log does not always get everything.
  • I don't have access to this, but I just asked my webhoster and he will look into it.
  • acrylian Administrator
    You don't have access to your server error log, not even through your host's backend maybe? That is really unfortunate and should really be available in some way.
  • My host took a look for me in the log files, but couldn't find any reference to ZP in any way. The problem has to be somewhere within the plugin or something I did perhaps to the theme, althought my theme is quite straight forward really.

    Here you can see that all images are not indexed:
    http://ompldr.org/vZmkybw/Selectie_029.bmp

    And here that the errors start with the images:
    http://ompldr.org/vZmkycA/Selectie_030.bmp

    And here the errormessage itself (missing xml tag):
    http://ompldr.org/vZmkycQ/Selectie_031.bmp

    I have no idea were to look further. None of the images are indexed in Google, either way, with or without sitemap :(.

    This is my code in image.php: printDefaultSizedImage(getImageTitle())
    and all my images have been cached, although they show up rather small in size, but that's because (I guess) because my larger images are already the right size:

    http://ompldr.org/vZmkydQ/Selectie_033.bmp
  • acrylian Administrator
    One of the screenshots as far as I understand notes an xml error in the image sitemaps. So how does that look like and what is it actually it is complaining about?
  • The imagemaps all look the same, like this:

    http://ompldr.org/vZmk0NQ/Selectie_034.bmp

    and then there is a reference to this:

    http://ompldr.org/vZmk0OQ/Selectie_036.bmp

    And Google is always complaining there is a xml tag missing:

    http://ompldr.org/vZmk0OA/Selectie_035.bmp
  • acrylian Administrator
    Yes, indeed the actual image links are missing and I can confirm I indeed can reproduce that on my live test install. http://support.google.com/webmasters/bin/answer.py?hl=en&answer=178636
    Now we have to find out why that got broken.

    However, Google really should also index the image itself via the albums and the site itself...

    Anyway I opened a ticket for it: http://www.zenphoto.org/trac/ticket/2245 All further discussion regarding test there.
  • Thanks! I will follow the comments there and test any changes that are suggested.
  • Funny, I just wanted to let you know how things are now and got the message the ticket is closed for this 'problem'. Never mind, I just wanted to let you know that the sitemap probably works fine, but that even after seven weeks the images are slowely being indexed. In this image you can see the WordPress sitemap and the ZP sitemap, split into a web part and an images part. The web part (I assume these are the .php extensios) are indexed much better than the images themselves:

    http://ompldr.org/vZ2YzbA/Selectie_196.bmp
Sign In or Register to comment.