bad links

there seem to be a few links that dont work or are out of date. I've just downloaded and successfully installed zenphoto. after the setup the administrate link pointed to an admin folder which didn't exist - i changed this to point to the admin.php file and it worked. Then the admin.php file failed to point back to itself after uploading.

this is the path requested after clicking 'upload' (after the domain name (the installation is in the folder 'zenphoto')) "/zenphoto/admin/?page=edit&album=me"
by editing the link in the address bar (ie changing /admin..... to /zen/admin.php..... ) it works.

Other links also dont work - clicking on browse gallery and then on an album fails to work. Also all the images (thumbnails etc) and album links dont work - they go to /zenphoto/[albumname]. All of my albums are in zenphoto/albums/[albumname]

It seems that something crucial is not quite right


  • The program should be abe to bring up the admin page with "admin/". It is a virtual folder created in the `.htaccess` line 13.

    Maybe the path to your root folder in the `.htaccess` file or in your `config.php` is incorrect?
  • by setting the $conf['mod_rewrite'] = false; the photos in the photo album start working. The admin area still fails to upload correctly. I still tries to point to here:


    with this error:
    The requested URL /~alistairm/mccportfolio/zp/admin/ was not found on this server.

    (i tried a complete reinstall of zenphoto into the folder 'zp')

    I've tried setting the mod_rewrite to true and setting the RewriteBase to:

    RewriteBase http://alistairms-computer.local/~alistairm/mccportfolio/zp/


    RewriteBase /~alistairm/mccportfolio/zp/

    any ideas?
  • trisweb Administrator
    It should work without mod_rewrite, except for the *link* to the admin pages. If you just type [zenphoto path]/zen/admin.php into your browser, then that should work as well.

    I'll make a bugfix release soon that fixes all these problems...
  • I'm having this same problem ... and I'm further stymied by the fact that my zenphoto install didn't include an .htaccess file ... ?
  • Nevermind about the .htaccess file; I figured that out via this thread:

    But I still can't get the system to work. /admin doesn't work by itself; it needs the .php suffix added. That's no biggie, but then when I attempt to upload a .zip at /admin.php?page=upload, after clicking "Upload," /admin.php?action=upload loads a blank page. The folder I specified is created in the albums directory, but it is empty. If I reload /admin.php?action=upload, I return to /admin.php?page=upload, which then includes this message: "Something went wrong ... You must upload at least one file."
Sign In or Register to comment.