HTTP_Accept_Language does not parse


When I wanted to have HTML coding in the description of the Gallery, I figured I should activate HTTP_Accept_Language. However, if I do that, and save the new setting, I get a message that the option Allow Tags could not be parsed.

I had just rerun Setup (to update MySQL settings), and everything seemed okay then.

Can you advise me on how I can correct this?

Thanks in advance


  • acrylian Administrator, Developer
    I am not sure what you mean with HTML coding in the description? If you mean using HTML in text you can do that but you have to switch the editor to source view ("<>" button) or disable it to enter HTML manually.

    The http-Accept language is actually to switch to translations based on the visitor's browser default setting. That will only work if you have that language actually and your server supports the locale/gettext functionality (as all translation/multilingual features).

    Regarding the error please post the actual error message. I assume Zenphoto 1.4.6.
  • Thanks for reacting and the suggestions. I probably confuse HTML with CSS. At any rate, what I mean to do is the following:

    I go to the tab Options-Gallery. I then write in the Gallery description box the description. In that description I want to add formatting like bold and colour and the like. For that I use an editor like BlueGriffon: I type my text and apply the formatting I want in WYSIWYG view, switch to Source view, and copy the text with the coding in the description box.

    I have two photo sites, both using the same theme. In one, this works. In the other, all the coding is removed upon saving.

    I then noticed that in the one that works, the option of http-Accept language was active, so I thought that had something to do with it. When I tried to activate it (via the Options-General tab in the version in which the formatting doesn't work, I got the message: "Your Allowed tags change did not parse successfully." I just tried, and it gives me that message consistently when I click the Apply button, regardless of whether I have changed something on that page or not. So maybe it does not have something to do with that option of http-Accept language (which is now in the activated position).

    I use indeed Zenphoto 1.4.6 in both cases, and the theme is ZpArdoise.

    I looked for a "<>" button on the page where I edit the Gallery description, but can't see one. I presume you refer to an editor like BlueGriffon, which has that, or the edit source function of a browser.

    I hope this clarifies the issue better. Thanks in advance for your advice.
  • fretzl Administrator, Developer
    On Options -> General -> Allowed tags you can see which HTML tags are allowed in text fields.
    These can be modified to your liking.

    My guess is that you are using tags that are not (yet) allowed.
  • acrylian Administrator, Developer
    Regarding HTML formatting: For some reason the TinyMCE editor is not enabled on your site. Just go to the plugins tab and enable the tinymce4 plugin. Then you don't have to copy back and forth. That would then look like this on any text field:

    The http accept langauge has nothing to do with that as I explained. The "allowed tags" however have as they tell Zenphoto which html tags to allow on saving. That should look like this:

    There is a "reset" button to re-set the defaults if it doesn't. If it doesn't parse you need to look at your (server) error log to find out the actual error message.
  • Thanks to you all. This solved all problems, and I learned something new. I had no idea that the TineyMCE editor was there for this purpose. I have activated it, and that makes editing these text fields indeed much easier. It also indicates instantly which fields can accept formatted text, and which fields can't. Sofar I had to find out by trial and error. And now I understand your earlier suggestion to look for the <source> button.

    Also thanks for the instructions concerning the tags. I must have been blind, because there were no tags at all in that option field on the tab Options-General. I must have by accident deleted it, and not noticed it, because I did not understand what it was for. Now I know, and I got it back by resetting it to default.

    Many thanks, problems solved.
Sign In or Register to comment.