Multilingual problems with gettext()

I try to set up a new website with zenphoto and have the multilingual part working except that gettext() translations does not work (e. g. using the zenpage or garland theme).
When I switch my language from english to german all text that can not be managed within the zenphoto admin pages remains english.
I opened zwnphoto.po from the german locale folder and have the feeling that the search path matches to a development system but not to the distributed version 1.4.6 (see following 2 lines from po-file)
"X-Poedit-SearchPath-0: zenphoto-devzp/themes\n"
"X-Poedit-SearchPath-1: zenphoto-devzp/zp-core\n"


  • acrylian Administrator, Developer
    Yes, those are the paths from my development version. But those only are needed if parsing Zenphoto to create or update a translation (see our translation tutorial if you want to read more about that) and are completly meaningless for normal Zenphoto use.

    If the static strings are not translated by switching your server probably does not support gettext(). Ask your provider about that.
  • gettext is enabled. I'm testing on a wamp installation locally and checked in phpinfo.
    I also tried to use gettext_th() inside a theme ("paradigm") but end up with the same result. And yes I did read the translating tutorial that you wrote ;-) Maybe i missed something there.
    Anyway thanks for the great work with zenphoto. I just started testing it 2 weeks ago and find it the most suitable for my needss.
  • acrylian Administrator, Developer
    I can assure the gettext part works on several local installations (MAMP since I am on Mac) here including live ones. The path in the po file can realy not be the problem. Are you really sure that the server does have the de_DE locale support? Otherwise it all will not work even if gettext itself is working.
  • Could be either x64 WAMP (as some posts I found in the web suggest) or the Windows installation I have to use here. Going to check it on my own machine and with my hoster. I think you're right that the machine has some flaws.
    Thanks for your help.
  • Verified it. My home system shows everything in german and gettext() won't work here, too because of the x64 wamp installation. If I find a solution for this I will post it here.
  • Found a related post in
    It appears to be bug in PHP 5.5 in combination with the Windows oddities of language selection. As I can see the translations work when I use the same pages on different machines (english and german). This will be fixed on my hosted domain as soon as I'm ready to go online.
    Need to prepare some more pictures to be uploaded :-P
  • acrylian Administrator, Developer
    Ok, thanks for the feedback.
Sign In or Register to comment.