Lightroom Publishing Service

Hi,
for those of you who are using the Lightroom Publishing Service:
http://philbertphotos.github.io/Zenphoto-Lightroom-Publisher/#download

and having problems using the plugin, I have modified the ZenRPC file which eliminates the following issues:
1. wrong album persmissions (chmod 644)
2. Error 500 messages when trying to create a new album from within Lightroom

You can downlaoad the modified file from my site:
http://www.ralf-kerkhoff.de/artikel/zenphoto-lightroom

Although the article is in german, you find the download link to the ZenRPC.zip file in this article.

Keep in mind:
Usage is completly on your own risk. Please be sure to have a copy of your zenphoto files on your local harddisc. And make a backup of your zenphoto database.

Cheers
Ralf

Comments

  • acrylian Administrator
    Great, alway appreciated as none of us uses Lightroom. Seems it has not been updated in two years according to the GitHub repo https://github.com/philbertphotos/Zenphoto-Lightroom-Publisher.

    Otherwise I would have suggested to contact him via a ticket. But you could fork the repo and offer your changes via a pull request maybe. If you take it over basically we might need to properly change the plugin entry on our site.
  • Hi,

    just an update:
    'My' modificated file works fine, until you create a dynamic album in Zenphoto. Dynamic albums means: those albums created on a search which are stored in the album folder with the 'alb' extension.

    I will get an error 500 in Lightroom and the error log in Zenphoto shows:
    'albumname.alb' is not within the allowed path.

    At the moment i have no idea to get this fixed.

    Ralf
  • acrylian Administrator
    I have no knowledge about Lightroom as I neither have nor use it or how this plugin works but you basically export albums and/or images from it to Zenphoto, right? Then of course dynamic album can't work as they don't "have" images physically. You can check if an album is dynamic via the object model method `$albumobj->isDynamic()`.
  • Hi,
    I have already checked the object model method but can't find what causes the problem.

    For me it is not that dramatic, because my album structure is ready and picture upload is possible without problems.

    Ralf
  • acrylian Administrator
    Maybe it is a issue of syncing back to LR then?
  • The article is available in english now - if you switch to english using the flag thum at the bottom of the site.
  • acrylian Administrator
    Great, thanks. I probably will create a separete extension entry for your updates. So the two versions are more clearly separated. Did you try to contact the original creator actually?
Sign In or Register to comment.