zenphoto_sendmail with zpbase

I am using zenphoto 1.4.6 official release with the zenphoto_sendmail plugin and zpbase theme. When I try to use the contact form to test whether it sends an email to the contactor or me as administrator, neither get an email. zenphoto_sendmail seems to send the contact information correctly or at lease it does not complain. I don't see any that there are any options settings available for zenphoto_sendmail. PHPmailer has options for setting the URL of the desired mail system.

I use yahoo mail as my standard email supplier Is there a way to set up the email vendor? What mail system does zenphoto_sendmail use as its default? Can anyone provide some guidance as how to get zenphoto_sendmail to work?

Comments

  • acrylian Administrator
    The zenphoto_sendmail plugin use the server built in PHP standard mail functionality. There is no configuration needed actually. But it might be that your host doesn't support or allow using it or it needs to be enabled. Best you ask your host.

    If you want to use an external mail provider like Yahoo you need in any case to use PHPmailer and configure it accordingly
  • I went back to PHPmailer because I was having too much trouble with my hosting service's email service and MS Outlook (OLMAPI32.dll errors.) Using the PHPmailer, I am haveinganother problem - which is why I was trying sendmail. I get failures on the from address - the error shows "phashfield@yahoo" rather than "phashfield@yahoo.com" I have tried both "phashfield" and "phashfield@yahoo.com" as user names - same failure. My PHPmailer settings are the correct password, SMPT (I have similar results with POP) smtp.mail.yahoo.com; SMPT port 465 (I am realy not sure what the port number should be but web searches seem to indicate that port); no SSL. Any suggestions?
  • fretzl Administrator
    That PHPmailer error is confusing. I ran into that one a few times myself and had to use a debug statement to find out that it simply could not connect to the server.(`$mail->SMTPDebug = 1;`)

    Your settings should be like this:
    https://help.yahoo.com/kb/yahoo-mail-pop-settings-sln4724.html

    Since you already tried port 465, I suggest trying port 587 and you should certainly use SSL.
Sign In or Register to comment.