Openstreetmap-Plugin

Can somebody help me with the openstreetmap-plugin?
http://jonnylander.dynasigns.de/zenphoto/Einkeimbl-ttrige-Pflanzen/Narzissengew-chse/Knotenblumen/Fr-hlings-M-rzenbecher/#4

The GoogleMap-Plugin on this page works fine, but the Openstreetmap-Plugin doesn't show up any marker.

What am I doing wrong?

Comments

  • acrylian Administrator
    Can't tell. Anything in the error logs? How did you call it on the theme? DId you try to disable the Google map plugin? I see some errors in the browser log at least.
  • hi, thank you for the quick reply.

    I insert it how it is discriped in the readme here:
    https://github.com/acrylian/zp_openstreetmap

    and insert the following code to the album.php:
    <?php printOpenStreetMap() ?>

    I do not understand anything about error logs and browser logs :/

    Cheers
  • acrylian Administrator
    I just tested the plugin with default settings with the official Zenpage theme on both `image.php` and `album.php`. I used your images from above for testing to be sure and it worked as intended for me.

    You need to learn about error logs if self hosting. The browser has a log (console) and Zenphoto has a debug (error) log. Additionally the server itself has its own php error log (and some more). About the latter ask your host where to find it.
  • fretzl Administrator
    Just did the same and it also works for me with the Zenpage theme but the effervescence_plus theme seems to specifically use the GoogleMap plugin. It's difficult to find out how and where to put the `<?php printOpenStreetMap(); ?>` code.
  • acrylian Administrator
    Maybe there is an incompatibility between the two. But that has not really been tested since you most certainly use only one of them at the time.
  • I deactivated the GoogleMap-Plugin and switched to the basic theme. I inserted the following code in the image.php and album.php.

    <?php
    @call_user_func('printGoogleMap');
    @call_user_func('printRating');
    @call_user_func('printCommentForm');
    printOpenStreetMap();
    ?>

    The map is shown, but without any markers.
    Any idea?
    You can find the page here: http://jonnylander.dynasigns.de/zenphoto/Einkeimbl-ttrige-Pflanzen/Narzissengew-chse/Knotenblumen/Fr-hlings-M-rzenbecher/M-rzenbecher-Pflanze.jpg

    Cheers!
    Jonny
  • acrylian Administrator
    No sorry, not at the moment. As said I used directly your images on my local install with the Zenpage theme and all markers showed as expected. Again, anything in the logs?
  • fretzl Administrator
    I see a cluster in the center of the map. A green(ish) circle with the number "4" in it.
    That's where the individual markers are concentrated. Click on the circle until the magnification is big enough to show the individual markers.
  • acrylian Administrator
    Ah, okay, in Firefox they are there but not in Safari and Chrome. That worked in my test in all browsers. Just retried…

    If there is a cluster on the single image you have "album markers" enabled. Try to disable that os only the marker of the image itself is show on the image page.

    Not that this would explain why they don't work here in some browsers…
  • I did not see a cluster.
    I disbaled album markers.
    Still the same problem.

    I used an online Website-Screenshot-App... and there WAS a marker!?!?!
    Seems like there is a problem with my browsers... IE and Firefox both do not show up the markers. I'm frustrated and do not know what to do... :(

    Do you see a marker on my link above?
    Jonny
  • acrylian Administrator
    Firefox yes, Safari and Chrome no. But on my local test install in all…
    http://www.zenphoto.org/test/osm-test1.jpg.html
    http://www.zenphoto.org/test/osm-test2.jpg.html

    Sorry, no idea right now.
  • fretzl Administrator
    If I follow your link I see a marker in Firefox, Safari and Chrome.(OS X)
  • acrylian Administrator
    Weird, this is what I see in Safari (OS X 10.9.5):
    http://www.zenphoto.org/test/osm-nomarker-safari.jpg.html

    And correctly in Firefox:
    http://www.zenphoto.org/test/osm-marker-firefox.jpg.html

    I thought first a CSS conflict but then why would it work locally with the same theme…
    I also checked if an adblocker or something is the cause…
Sign In or Register to comment.