Upgrading question. Fatal Errors

it's been a while since I've upgraded my gallery (was 1.4.x) so I decided to do the update.

done everything as usual. but for some reason I kept getting errors after the installation was completed and I couldnt open any page.

I couldn't open the admin page getting this error:
Fatal error: Class 'Zenpage' not found in /zp-core/zp-extensions/zenpage/zenpage-admin-functions.php on line 10

and as a visitor:
Fatal error: Call to undefined function printRSSHeaderLink() in /home/alriya2/public_html/photography/themes/zpgalleriffic_v1.4/header.php on line 68

I know this is an unsupported theme but just a pointer would help.

or should I just restore my site from my backup?



  • acrylian Administrator
    The first error is strange since both the file reporting it and the "missing" class are part of the same plugin. You need to look if really everything is in place and that file/folder permissions are correct. The latter could cause such things but it's just a guess. Your server PHP log should tell something about that.

    `printRSSHeaderLink()` is part of the rss plugin. So enabling that should fix it. The theme apparently does not check that.
  • Thanks Acrylian for the fast response. I'll check the 2nd error once I am able to take care of the first since I cannot enter the admin center.

    Everything is in fact in place since I simply deleted all old files and uploaded the new ones.

    what would be the correct permission number and on what folders?
  • acrylian Administrator
    Take a look here for the recommend permissions:
  • Thanks. I checked and I have the suggested permissions already. All directories are 0755 and files within are 0644.
  • acrylian Administrator
    Also check as noted that the server user/owner is the right one. Some hosts use a different one for FTP when uploading and another for executing scripts.

    Also please review your server logs. You also might have a compatibility issue with PHP.

    Otherwise I can only suggest to re-upload the whole install again in case anything screwed via ftp.
  • Thanks Acrylian. I've tried multiple solutions but all didnt work and the server side support couldnt figure it out. So I decided to restore my site from the backup. All done and reran the setup script. some pages open and some dont. Admin overview page for example wouldnt load, but other admin pages load.

    in all cases, wither the pages load or not, I get many warning messages on the page. these are a few messages:

    Warning: Invalid argument supplied for foreach() in ***/zp-core/lib-auth.php on line 560

    Warning: Cannot modify header information - headers already sent by (output started at ***/zp-core/lib-auth.php:560) in ***/index.php on line 150

    Warning: preg_match() expects parameter 2 to be string, array given in ***/zp-core/functions-i18n.php on line 479

    Warning: strip_tags() expects parameter 1 to be string, array given in ***/zp-core/template-functions.php on line 32

    any thoughts?
  • acrylian Administrator
    Sorry, I sadly have no real idea except mentioned. Permissions or possibly incompatibilities. If you haven't try an official theme as zpGalleriffic may very well be the reason being not maintained.

    Also if you use any third party plugins please remove them and try then.

    You said you upgraded from 1.4.x. What version was it exactly? You shouldn't have had any problem with 1.4.7 or newer (note that version umbering changed afterwards a bit). But if you had an earlier version I have to suggest step by step upgrades.
  • I think from a file I had it was

    I did the step by step upgrade but I faced those issues mentioned.

    I've also tried to change the theme from the crippled admin center to a default theme but same warning messages and unloaded pages.

    I also dont recall adding any 3rd party plugins but I cannot load the plugins page anyways.
  • acrylian Administrator
    Just check the /plugins folder of your install via ftp and remove anything within (naturally backup anything you might need later). Otherwise I sadly have no idea anymore. A wrong htaccess file or a wrong rewrite base could cause things. A link to the site could help though.
  • Thanks Acrylian. it may be something with the server side permissions. I restored my site to its former glory following a db restore by the host
  • acrylian Administrator
    Glad that you managed it at last!
Sign In or Register to comment.