no such file or directory (synology nginx mariadb)

I am stuck on this error of the setup script while trying to install zenphoto on a synology nas with nginx php 5.6.30 mariadb10
I have created a zenphoto in mariadb10 database with phpmyadmin.
All circles are green and checked.

I have tried to manually define webpath to /volume1/web/zenphoto without success.

I am looking for clues and help.



  • Is there more details of the error message? Maybe a line number, etc.?

    What is the link address shown for phpmyadmin in the browser? What is the link address shown for setup when you have all the checkmarks?
  • setup.log file say:

    Query error: No such file or directory

    Web guy say:
    PDO::MySQL rapporté : SQLSTATE[HY000] [2002] No such file or directory


  • acrylian Administrator
    None of your links work with a "server not found". Zenphoto generally should work on Nginx (this site currently is on Nginx as well). MariaDB should also generally work although we don't test it (I once could briefly a few months ago and there were no issues).

    I have no access or experience with Synology but are you sure you installed Zenphoto in the location you are trying to access?
  • The server is not routed to internet.
    I have set it up to test zenphoto localy.

    I think that the problem may be with webpath and serverpath options in the .cfg

    If someone had already make it run under DSM 6.x I would be pleased to have information about theses paths.
  • acrylian Administrator
    I assumed the links are local only. I have no idea how synology works. If the local server on it works like local servers like MAMP, LAMP etc. (on these you normally don't need to set anything via the config file) there should be some info about that somewhere. Again I have no knowledge about synology but installing Zenphoto cannot be that different as from other toods…
  • Finally, I don't know if this is a path problem because setup page say (in french):
    (red circle) database parameters in the configuration file

    How can I do more simple than that: I have created a "zenphoto" user with a "zenphoto" database without password at localhost.

    I have modified the paths in the .cfg.php file, with no difference of the error message.

    Arrrgghhhh .... no way !

    here the setup screenshot:
  • acrylian Administrator
    Now we are getting nearer. So it is the database credentials that are wrong and not paths.. I didn't know you can access databases without any password at all. No "real host" will allow that so just define a password for that user and enter it there. Zenphoto in any case expects one.

    If that doesn't work, it may also be that PHP is not correctly configured to use MySQL. I can't help with that as I never setup my own servers.
  • I have tried first with password, but no differences.
    PHPinfo file give many informations, too many, I cannot say what is normal and what is not.

    PhpMyAdmin can connect to mariadb10 but not adminer.
    I am uninstalling mariaDb10 to try with mariaDb 5 ...
  • acrylian Administrator
    It still might be an issue between the PHP extension PDO and the database itself. Maybe try MySQLi instead. I fear you need someone who actually has knowledge in server setup itself. Zenphoto generally works with standard setups as found on shared hosting, so nothing really complicated should be needed normally.
  • I have tried different engines MsSLi/PDO/SQL ... same results
  • acrylian Administrator
    Sorry, no idea then except the mentioned possible not correctly setup server regarding the databse.
  • It's ok with mariadb5, and adminer can connect to it !
    Maybe the port number ... I will give it a try to run zenphoto under synology DSM6 PHP7 and maraDb10.
Sign In or Register to comment.