Support Build 1.2.2018 + PHP

Tried to update 1.4.14 to current support build.
It failed.
"Zenphoto requires PHP version 5.6.0 or greater."
Our server is running (Debian Squeeze)


  • acrylian Administrator, Developer
    edited February 2018

    We primarily develop on PHP 7.1+ only and the lowest we can test at all is PHP 5.6. All below are deprecated PHP versions. PHP 5.3 has reached his end of life quite some time ago in 2014. Your webhost should really provide at leasat 5.6 or better to PHP 7 (which is much faster, too) nowadays.

    Although we don't strictly code PHP 7.1+ only (for pragmatic reasons as we cannot rewrite everything that is working), we therefore cannot guarantee that it works on 5.3. Therefore we decided to make that stricter for the next version already.

  • Would be better if the next version is called 1.5 instead of 1.4.15

    After I saw ZPC 1.4.14 running on the server I just told our service provider that I don't want him to upgrade the server. :D

    If we would upgrade it, then I would need to upgrade other installations as well as they won't run with 5.6 or higher. This would cause panic as I simply have no time to do all that @ the moment...

    Furthermore we would not have PHP7.1 but 7.0 which comes with Debian Stretch (latest stable).

  • acrylian Administrator, Developer

    I do understand. But some time you will have to as lots of other tools will also require this sooner or later (or plugins for them will). In the future even libraries we use may require this itself.

    Can't you set different PHP versions per directory on your host? Or maybe you could use subdomains with different ones? On my host that is easily possible.

    We maybe think of making this less strict with a clear warning of no guarantee on below 5.6 again. Don't think that other changes justify 1.5 already but we'll think about that ;-)

  • Ok, I am downgrading back to 1.4.14 and I am forced to stay with it until I know how to proceed with the other applications.

  • I would recommend to name the upcoming Support build 1.5 :)

    The PHP requirement is a braking change for all those who "just press the upgrade button" - like me. ;)
    I think that the PHP requirement is justifying the change of this decimal.

    It is later easier to write 1.4.15 than 1.4.14.x if some furter effort is taken with the 1.4.14 ;)

    And there are still some decimals left till reaching 2.0

  • acrylian Administrator, Developer

    We actually already decided that because of that. However we changed that it will allow to install on older PHP versions but with an error message that it's on your own risk.

    You respectively your hoster needs to take care of this soon. If we don't cause a real proper incompatibility some third party libraries used may do so in the future for sure.

Sign In or Register to comment.