Can't get in to admin

Been a while since I've done anything with any of my Zen sites but today I went to sign in to a customers site to make some changes and I'm getting an error. On the sign in page above the form I see the below messages - and it won't let me log in.

Warning: session_start() [function.session-start]: open(/home/content/49/2544849/tmp/sess_3123dodbfbuobqml016fp6k7s7, O_RDWR) failed: No such file or directory (2) in /home/content/49/2544849/html/zp-core/functions-basic.php on line 1565

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/content/49/2544849/html/zp-core/functions-basic.php:1565) in /home/content/49/2544849/html/zp-core/functions-basic.php on line 1565

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/49/2544849/html/zp-core/functions-basic.php:1565) in /home/content/49/2544849/html/zp-core/functions-basic.php on line 1565

Warning: Cannot modify header information - headers already sent by (output started at /home/content/49/2544849/html/zp-core/functions-basic.php:1565) in /home/content/49/2544849/html/zp-core/functions-common.php on line 502

Warning: Cannot modify header information - headers already sent by (output started at /home/content/49/2544849/html/zp-core/functions-basic.php:1565) in /home/content/49/2544849/html/zp-core/functions-common.php on line 502

Warning: Cannot modify header information - headers already sent by (output started at /home/content/49/2544849/html/zp-core/functions-basic.php:1565) in /home/content/49/2544849/html/zp-core/admin-functions.php on line 104

Warning: Cannot modify header information - headers already sent by (output started at /home/content/49/2544849/html/zp-core/functions-basic.php:1565) in /home/content/49/2544849/html/zp-core/admin-functions.php on line 105

As mentioned I haven't done anything is a while so not sure why these messages are coming up. Don't know version either...

Thoughts?
Thanks,
Mike

Comments

  • acrylian Administrator

    No actual idea. Maybe any server update meanwhile is the cause of this, apparently it does not find the location to store session cookies which is normally a server set location.

    What Zenphoto version is this?

    Of course it is generally recommend to look at sites regulary even if you don't do anything on it. Even for liability in case anything serious goes wrong and harms visitors. This of course does apply to all CMS out there.

  • The site loads fine - just not the back-end. I'll keep at it see what I can find...

  • acrylian Administrator

    Okay, that's at least sort of good sign. Best also check your php server error log if there is anything else.

  • Well I was able to swap out the zp-core folder for a backup I had. That at least got me in to the backend but broke a few things on the front end. But once logged in I reverted back to the original zp-core folder and frontend is fine again but the backend still shows errors but at least loads the admin stuff for editing the site.

    So for now I'm Ok - will have to investigate what's going...

  • acrylian Administrator

    If you used the zp-core folder of the same version that should not break things on the frontend unless you did some modifications somewhere…

    Anyway, sadly I have no real idea from here.

Sign In or Register to comment.