Stuck in setup

My gallery has been running flawlessly for several years, now all of a sudden it stopped. I don't remember the error, but I decided to install the update. Now I am stuck on the setup page with this error:

Welcome to Zenphoto! This page will set up Zenphoto 1.4.14 on your web server.

Systems Check:
Installing Zenphoto v1.4.13
zp-data security
PHP version 5.6.34
PHP Sessions.
PHP Register Globals
PHP Safe Mode
PHP magic_quotes_gpc
PHP magic_quotes_runtime
PHP magic_quotes_sybase
PHP display_errors
PHP gettext() support [is not present]
Warning!

Localization of Zenphoto requires native PHP gettext() support

PHP flock support
Testing mb_strings.

Any help is appreciated.

Comments

  • jfutral Member

    Sorry this "Installing Zenphoto v1.4.13" should read this "Installing Zenphoto v1.4.14"

    Joe

  • acrylian Administrator

    What PHP version does your server have? Errors in the server PHP error log or elsewhere?

    If the server meanwhile upgraded to PHP 7 or something, 1.4.13 may cause some trouble as it is not fully compatible. You should be using 1.4.14 in any case.

    The gettext warning is not important unless you need to use other languages than the native English.

  • jfutral Member

    Yes, it is v1,4,14 (I corrected it in the next post. PHP v5.6.34.

    Right, I don't really care about the gettext. What I do care about is I can't get past this screen, though. Makes it unavailable to clients who want to see my work portfolio.

    Not sure where to find the PHP server log, but will poke around.

    Thanks,
    Joe

  • acrylian Administrator

    You can take a look at zp-data as there are ZP's own logs. But the PHP server log is better. Ask your host about it. It might be only available on request (on my I have to enabled it first), via backend or even SSH… every host is different…

  • jfutral Member

    So I found these from the last time I tried to visit my gallery.:

    [10-Apr-2018 02:58:20 UTC] PHP Warning: require_once(/~/zp-core/version.php): failed to open stream: No such file or directory in /~/zp-core/global-definitions.php on line 6

    [10-Apr-2018 02:58:20 UTC] PHP Fatal error: require_once(): Failed opening required '/~/zp-core/version.php' (include_path='.:/opt/cpanel/ea-php56/root/usr/share/pear') in /~/zp-core/global-definitions.php on line 6

    "~" = directory path editing for my own security, but is all the same info.

    Does this help narrow down the problem?

    Thanks,
    Joe

  • acrylian Administrator

    Did you check if that file actually exists? If it does and you still get the error you might need to check your file/folder permissions. Info about the recommended ones (differs also from server to server) you find here: http://www.zenphoto.org/news/permissions-for-zenphoto-files-and-folders/

  • jfutral Member

    Yes the file exists. I'll check permissions, then.

    Thanks!
    Joe

  • jfutral Member

    Grr. Permissions are as they should be.

    Joe

  • acrylian Administrator

    Hm, then I sadly don't have any idea right now. Unless you find any other errors… Maybe as a currently helpless idea try a re-upload of zp-core, sometimes FTP upload messes up permissions/owners…

  • jfutral Member

    Will do.

    Thanks,
    Joe

  • jfutral Member

    So I found another Error log with this:

    [Tue Apr 10 08:42:40.488047 2018] [core:error] [pid 54973] (13)Permission denied: [client 216.244.66.246:48240] AH00132: file permissions deny server access: /~/robots.txt

    This one is logged many times.

    Joe

  • acrylian Administrator

    That's now permissions but robots.txt here should not harm setup to be run. Maybe it is still all permissions in the end. On some servers you need for some reason less than optimal.
    Or the file owner is for some reason not the owner that runs PHP processes? That can lead to "funny" results…

  • jfutral Member

    I'm going to try a clean install and see where that gets me. RTZ!

    Joe

  • jfutral Member

    Well, that was a fail and now this is added to the screen:

    zp-data security [is compromised]
    Warning!

    Zenphoto suggests you make the sensitive files in the zp-data folder accessable by owner only (permissions = 0600). The file permissions for setup.log are 0644 which may allow unauthorized access.

  • acrylian Administrator

    That is not necessarily an issue or "showstopper" for running setup, just a warning. This is a stricter permission that not even works on every host (as mentioned all are different).

    Sorry, unless you can provide some more errors from the PHP error log, I sadly will not be able to help. Zenphoto runs on fairly standard configured (shared) web hosts without any problem and I installed it on quite a few.

    Maybe this is sadly the point to ask your host for help?

  • jfutral Member

    Great suggestion! While rooting around I noticed my host promotes ZenPhoto as one of the recommended image gallery solutions, so I figure, sure why not?

    The problem was an old suPHP line on my root htaccess file. They fixed that and FINALLY all is good. Apparently that was what was causing the PHP gettext warning.

    Lunarpages rocks. Just sayin'.

    Joe

  • acrylian Administrator

    Great that you managed it! It really shouldn't have been that hard ;-) Thanks for the follow up!

  • jfutral Member

    I just wish I was smarter at these things and more interested in backend stuff like when I was younger. These days I just don't have it in me anymore.

    Still one of my favorite internet products. That I went three years without a problem, without even logging in (I also had to reset the admin login, as I couldn't even remember or find my login credentials!) speaks volumes.

    Joe

Sign In or Register to comment.