1.5 : no more thumbs on txt files.

Hello,

Using a localhost Zenphoto galery, I updated from 1.4 to 1.5.

I'm using txt files to display panos (iframe ...) and other elements.

Now, the corresponding icons are gone in my thumb pages.

In 1.4, I used for example :
mypano.txt
mypano.jpg
in an album, and the .jpg file was used as thumb.

I'm probably missing something ... will search a bit more and report here later.

Here are some thumbs not showing for example

Alt text

Comments

  • ctdlg Member

    Here is what I got before (version 1.4)

    Alt text

  • acrylian Administrator
    edited May 28

    I am quite sure we didn't change anything regarding the textobject plugin. Sure the plugin is still active?

    I cannpt reproduce anything locally and even our own site uses it as before:
    https://www.zenphoto.org/screenshots/screencasts/

    Do you have a link maybe?

  • ctdlg Member

    Hello acrylian

    I run my tests on a local computer (http://localhost/index.php)

    I erased my 1.5 version (everything), restored my /srv/http folder
    Also restored the database to 1.4 version.

    Everything was displaying fine.
    Then, again, I upgraded.

    It seemed to work, BUT
    I erased the cache ... and unable to recreate thumbs from txt files having a jpg picture. See above pictures.

    I've got one last thing to try : erase the cache under my 1.5 version, because I also upgraded my archlinux apache

    php 7.2.6 might be incompatible.

  • acrylian Administrator

    We will try to reproduce. I doubt that PHP 7.2.6 is the problem as surely not that much changed fom 7.2 which we are on currently ourselves.

  • ctdlg Member

    So, I reverted to 1.4.14.
    I cleaned both caches (pictures and html)
    No problem : txt thumbs are recreated as well as picture and albums thumbs.

    What else could I do to check the 1.5 version.

    I did follow this page to upgrade :
    https://www.zenphoto.org/news/installation-and-upgrading/
    using it from point 4 as my backups are already done.

    php 7.2.6 is compatible with zenphoto 1.4.14.

  • acrylian Administrator

    I could not reproduce it locally. I cleared the complete image cache manually and got all text object thumbs back as intended.

    I even tried the same on our site here:
    https://www.zenphoto.org/screenshots/screencasts/
    As you see all thumbs are there.

    There is indeed one minor change in ZP 1.5. regarding caching. We append a query to the cached image url ?cached=<timestamp> so browser have guide if they need to recache or not. But this should not cause this trouble.

    Any acutal error log entries (zp debug log and php error logs)?

  • ctdlg Member

    acrylian,

    I tried to install a fresh 1.5 zenphoto on my localhost : nothing happens.
    I tried a fresh install on an ovh server : nothing happens.

    Of course, I tried the zp-core/setup.php address.
    And folders permissions are 755 /644 (777 for albums, etc)

    About upgrading : nothing in debug logs.
    The admin page (album -> images) only gives me txt files without any thumb on the left side.

  • acrylian Administrator

    I am sorry if you cannot provide any actual error message or similar I cannot help since I cannot reproduce it. Nothing changed to my memory how these sidecar images itself are handled.

    Please try if it works with video/audio files for you as those use the same principle (actually all non image types if enabled do that).

    If you have a live install please send a link. Mail me if you don't want to do in public.

Sign In or Register to comment.