Xampp - ZP setup

I am doing a fresh install of ZP on my local windows box, on a new install of Xampp. I can't get the setup file or even the index file to load. I've made some basic PHP files for testing and they all run fine.

Every time I try to load:
localhost/gallery/index.php or,
localhost/gallery/zp-core/setup.php

My chrome browser will default back to a previously successfully loaded page such as "test.php", which will load fine.

Anyone with Xampp experience know what would be causing this? Tried firefox also.

Everything worked fine on an older install of Xampp. (of course) LOL

Tags:

Comments

  • acrylian Administrator

    I don't know XAMPP as I am using MAMP but you have to use the default port 80 for Apache in case it uses something different by default (as MAMP and WAMP seem to do).

  • tplowe56 Member

    This is copied from the PHP log, this happens when I try to launch the ZP index.php file.

    [12-Jul-2018 18:25:21 Europe/Berlin] PHP Notice: Use of undefined constant SERVERPATH - assumed 'SERVERPATH' in C:\xampp\htdocs\gallery\zp-core\reconfigure.php on line 72

    [12-Jul-2018 18:25:21 Europe/Berlin] PHP Warning: file_get_contents(SERVERPATH/zp-core/Zenphoto.package): failed to open stream: No such file or directory in C:\xampp\htdocs\gallery\zp-core\reconfigure.php on line 72

    [12-Jul-2018 18:25:21 Europe/Berlin] PHP Notice: Use of undefined constant SERVERPATH - assumed 'SERVERPATH' in C:\xampp\htdocs\gallery\zp-core\reconfigure.php on line 80

    [12-Jul-2018 18:25:21 Europe/Berlin] PHP Notice: Use of undefined constant SERVERPATH - assumed 'SERVERPATH' in C:\xampp\htdocs\gallery\zp-core\reconfigure.php on line 218

    [12-Jul-2018 18:25:21 Europe/Berlin] PHP Notice: Use of undefined constant PROTOCOL - assumed 'PROTOCOL' in C:\xampp\htdocs\gallery\zp-core\reconfigure.php on line 36

    Does this give you an idea what I have to change?

  • acrylian Administrator

    Yep, sorry, that's a bug. Not my day today. Same issue as here: https://forum.zenphoto.org/discussion/comment/1980540#Comment_1980540
    So please try the support build (master) from Github.

  • tplowe56 Member
    edited July 12

    Yes!!!, just found that on github, installed the 1.5 support build and seem to be getting somewhere.

    Thanks!

Sign In or Register to comment.