unable to use https option

hi
I want to migrate to https with my zenphoto sites (1.5)
I use Let's Encrypt SSL on server side, and SSL certificate seems to be installed and my test site is now accessible with https protocol (https://test.vincentbourganel.fr).
But on zenphoto admin (options>security), I am unable to choose https for server protocol option.
whatever I do, I remain with http value.

what going wrong?

Comments

  • acrylian Administrator

    Wild guess, is your config file set to http perhaps? It probably takes priority over the option. Have to review that.

    Besides that we also use Let's Encrypt on your site and as you see it generally works. But our config file is also set to https.

  • yes, I have these lines in my config file:

    // Server Protocol
    $conf['server_protocol'] = "http";
    

    I try to change the value to https but nothing change : I remain with http value in admin

  • acrylian Administrator

    That's weird as we really did the same for the main site and the demo… That would be the only thing I could think of currently. Log entries maybe?

  • when I run a setup from https://https://test.vincentbourganel.fr

    I have a lot of errors in debug log

     {29209:Tue, 17 Jul 2018 21:45:43 GMT} Zenphoto v1.5
    
    EXCEPTION (0): Call to a member function query() on boolean in /.../public_html/zenphoto__test/zp-core/functions-db-MySQLi.php on line 73 
    
  • more informations:

    • when I change server_protocol option from http to https in admin, the value remains http, but the server_protocol value in my db changes to https and the server_protocol var in config file changes to https.

    • when I run a setup from https://test.vincentbourganel.fr, I have som red crosses on plugin setup and a red cross for mode_rewrite.
      and I have the same number of entries like above in my debug log. on each retry, the red crosses are not o the same plugins.

    • nothing changes in the debug, if db and config values are manually set to http or https.

  • acrylian Administrator

    Please try the support build. There is a bug in 1.5 regarding a path constant that might cause your trouble.

  • as far I can see, nothing changes with the support buid.

  • acrylian Administrator

    We're investigating it.

Sign In or Register to comment.