Zenphoto evaluation: cache issue

davidarnoult Member
edited September 19 in General support

Hello Zenphoto community!

For many years, I have been using Drupal 6 + Gallery2 (menalto) combination to build a proper extendable CMS, getting all both world advantages. It rocked for many years. As you know, Gallery2 is now dead and Drupal 6 obviously old. The excellent module to integrate G2 in Drupal 6 is no longer developped either. But it does an excellent job.
One of the main feature of the web site is the newsletter facility: Using drupal newsletter template with gallery2 content integration, I can send scheduled daily newsletter of photo gallery using criterion like photo of the day, best viewed photo, best viewed album, special tags etc... My users quite enjoyed that ;-)
My current photo publication workflow is : Camera (RAW format)>Adobe Lightroom>Gallery2 through using specific export module in JPG or import by hand on server

As you know, technology is moving forward and security with PHP updates are becoming a real issue. Then I definitely need to move on and prepare migration to another system, mostly one photo CMS oriented.

After having eliminated Drupal itself as a solution (too far from the photo world), I have selected and been testing for months 2 serious systems that could replace my current one: Piwigo and Zenphoto.

Zenphoto is a very good candidate with a good API/theming engine and strong documentation/dev resources, I quite like that.

I am evaluating right now its performance. Finding it slow; I am exploring cache facility and it seems that I have problem with it with erratic behaviour. For some unexplained reason, some images cannot be pre cached generated.
I repeated the process and finally succeed in except one image.
It seems that size matters. I have setup imagemagick to ensure better conversion.
I am using basic theme.
Some example with debug
Album: [ 2017/lisbonne ], Image: [ 2017-01-20-172918-lisboa-pt-2.jpg ]
http://zen.arnoult.com/zp-core/i.php?a=2017/lisbonne&i=2017-01-20-172918-lisboa-pt-2.jpg&s=100&cw=0&ch=0&q=75&t=1&wmk=!&check=52612b46f0016886270efe834971d5faedb65d04

Image filesize: 21324420

Debug i.php | Arguments:
size = 595
width =
height =
cw = 0
ch = 0
cx =
cy =
quality = 85
thumb =
crop =

Album: [ 2017/lisbonne ], Image: [ 2017-01-20-172918-lisboa-pt-2.jpg ]

Image filesize: 21324420

Debug i.php | Arguments:
size = 100
width =
height =
cw = 0
ch = 0
cx =
cy =
quality = 75
thumb = 1
crop =

On the front end, the image cannot be generated either on the go.
I have extended memory using htaccess
php_value memory_limit 512M
With no effect

Is there a way to check with debug why the generation fails?

Thank you for your advice

David

Comments

  • acrylian Administrator
    edited September 19

    Thanks for the kind words in general ;-)

    Generally Zenphoto caches on request, when it is needed. Systems like Piwigo if I am not mistaken precache general sizes already on uploading. Which makes it seems faster. But themes or plugins can define their own custom sizes.
    So the first access to a theme page with uncached images may be slower. But only once. You find some info about that if you haven't already here: https://www.zenphoto.org/news/caching/

    The cachemanager can only cover image to pre-caching if all custom sizes a theme or plugin may need are properly registered.

    If you can you should try the support build (master) From GitHub as there as been some work regarding the cachemanager just recently. Testing is welcom.

    Why caching or more exact image processing failes can have several reasons. The most important one is the dimensions/resolution (not file size!) regarding memory usage:
    https://www.zenphoto.org/news/problems-with-albums-and-images/
    512m sounds good but if your image has a huge resolution it may cause trouble.

    Other reasons can be corrupt meta data. The php server log and/or Zenphoto's own debug log should tell a fiew things. You can also click on the thumb (or icon in the master) on using the cachemanager to get some info about the image processing.

    Hope that helps for a start.

  • Thank you Acrylian. I will check with github version. How do you activate Zenphoto debug log?

  • acrylian Administrator

    The GitHub version is the 1.5.1beta so best don't try on an important live site.

    The general debug log is enabled by default. You can also enable "test release" mode using the markRelease plugin.

  • Thanks! I have identified the problem and solved it: php_value max_execution_time was too short. I modified it in htaccess and it has generated the image ;-)

    Other question: Do you have any idea when the next major release will be available? I will probably wait for it before migrating as it will be a big step for me...

    Merci.

    David

  • acrylian Administrator

    Good you found out! php_value max_execution_time is surely direclty related to the sizes (dimensions) of your image in question. The larger the more time it might take to process depending on the server additional to possible memory issues.

    Sorry, we still cannot tell any specific date for the next major release. Too many things unfinished since we also have to work on 1.5.x. It's sadly all about time issues. We know we are way behind everything and are not really glad about it ourselves.

    I would not wait for that right now especially. We generally try to keep that major release as compatible as possible but changes are not avoidable.

Sign In or Register to comment.