How do I create an "About" Page

Hi, I have created my site. I would like to put in a page which tells visitors a little about me and my interests.
How can I do that ?

Tags:

Comments

  • acrylian Administrator
    edited November 25

    Depends on what theme you are using. If you use a theme that supports the Zenpage CMS plugin enable that plugin and you will see a main menu entry for "Pages". If the theme supports it it should also have some standard menu for it.

    If the theme does not support this plugin you can create a static custom theme manually. Infos about that on the theming tutorial.

  • Hi, I should have said that I am using zp-Ardoise theme

    More information
    About page and contact form not working" main body - "I've just enabled zenpages and the admin section is working, however, the front page just redirects me to 404 error page not found.

    Could anyone please point out if there is a silly setting I'm missing or if i have a permission not enabled please.

    https://photosbyrichard.net.au
    I'm trying to get an about me page and the contact page working"

  • fretzl Administrator

    I see that every link results in a 404 page.
    Difficult to guess what could be wrong here.
    Please check the Zenphoto debug log and possibly your server logs.
    One easy thing to try is to simply run setup again.

  • Ran Setup again and that didn't solve the problem , problem started when we activated the pages plugin

  • I also did a database restore and that didn't help either

  • fretzl Administrator

    Try the "official" Zenpage theme and see if the problem persists.
    Nothing in the logs?

  • Richardp Member
    edited November 24

    Hi, The problem appears to be in the .htaccess file
    My hosting support team modified the htaccess file to redirect users who type in photosbyrichard.net.au to https://photosbyrichard.net.au
    but it doesn't like this code.
    When I mark it out it is ok.
    Can someone fix the htaccess file for me please so it works ?
    Thank you
    Richard

    # htaccess file version 1.4.12;
    #   Rewrite rules are now handled by PHP code
    # See the file "zenphoto-rewrite.txt" for the actual rules
    #
    # These rules redirect everything not directly accessing a file to the Zenphoto index.php script
    #
    <IfModule mod_autoindex.c>
        IndexIgnore *
    </IfModule>
    <IfModule mod_rewrite.c>
      RewriteEngine On
    
      RewriteBase /
    #   RewriteCond %{HTTPS} !on
    #   RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
    #   RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
    #   RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
    
      RewriteCond %{REQUEST_URI} !(/$|\.)
      RewriteRule (.*) %{REQUEST_URI}/ [R=301,L]
    
      RewriteCond %{REQUEST_FILENAME} -f [OR]
      RewriteCond %{REQUEST_FILENAME} -d
      RewriteRule ^.*$ - [L]
    
      RewriteRule ^.*/?$                        index.php [L,QSA]
    
    </IfModule>
    
  • That is odd the #'s have disappeared and the text is enlarged and bold anyway that bold text causes the 404pages can some one fix it so it does what I am told it should do ?

  • fretzl Administrator

    Un-comment those 4 lines in the .htaccess file again.
    Go to Options => Security => Server protocol and set the option to https.
    Please also carefully read the info next to the option.

    Btw, to properly display a piece of code like that in a comment put it between 3 backticks (```your code here```)

  • Thank you :) The redirect works successfully with Firefox but not with Edge for some reason..

  • fretzl Administrator

    Must be browser cache. Empty the cache and history.

Sign In or Register to comment.