1.4.14: Image Title - Image Description

Where does ZP take the content from the image to fill these fields?

"Problem" I am facing is, that in my ZP-install both fields have the same content.

What do I need to do to have an blank title field?
Or where do I need to enter the picture title before uploading to ZP?

My workflow:
With Gimp (2.8.18) the "comment" field in image/image properties is filled.
With Digikam (5.3) "Edit EXIF" the field "Caption" gets filled with the same "Gimp-comment"-content and Digikam automaticly enters this content again in EXIF-"Description" and caption IPTC-"Description" and XMP-"Description".
The EXIF-"name", IPTC- and XMP "headline" fields remain empty.

Thanks.

Comments

  • acrylian Administrator

    Take a look here please : https://www.zenphoto.org/news/zenphoto-image-metadata-processing/

    Note that EXIF is not a fixed standard, several vendors are know to do things off the "specification". IPTC is different and XMP is an invention by Adobe (unless mistaken).

    Note that 1.4.14 is not the latest release (although nothing changed here to my knowledge).

  • Thanks for the link!

    Off topic:
    I am aware that "my" version isn't the latest - but I have to get started and I don't want to go with Piwigo for this project...

  • fretzl Administrator

    Sure! Thanks :-)

  • Can I ask a related question please? I had some images where I wanted to amend the caption, which had been read from embedded ITPC/XMP. Rather than directly editing the captions in the admin section of my gallery, I thought I'd edit the master copies on my PC, reupload them and refresh the image metadata. I'm fairly certain that I did this once before for tags and it worked, but for the captions the metadata refresh didn't seem to pull in the edited caption, and I had to edit them in the gallery admin. Is this supposed to work for captions? Is it working for other people and I'm doing something wrong?

  • acrylian Administrator

    This is supposed to work for all meta data. Are you sure you enabled the related meta data fields on the options? You can disable certain ones or all if you don't need them to save some overhead.

  • Would you be so kind as to direct me to which options I should ensure are enabled? There are a lot of options. Under Options | Image | Metadata, "Caption" is not enabled for display, but this is only metadata display, and it is enabled for processing. After all, the caption /description was imported at ingest. If this is supposed to work then I'll do another test.

  • acrylian Administrator

    I would try to enable all fields for processing, meaning the importing. "Display" refers to the display on the table on the theme metadata display. As discussed this is not an exact specification so you have to try a bit.

  • Well, it's working now. In fact it worked without even having to do a refresh, which really surprises me. I don't know what happened last time. Let's put this down to operator error. Thanks for the support.

  • acrylian Administrator

    Good you figured it out respectively it did by itself.

Sign In or Register to comment.