1.5 SB 22.11.2018: Fatal Error with functions-basic.php

I am currently working on an step by step upgrade from 1.4 to 1.5 support build on a server with PHP 5.3.
Exec not available.

If just copy and pasting the 1.5 support build files, the upgrade won't be executed as PHP-version is too low.
If doing a "step by step upgrade" it basicly works. Except with one file: /zp-core/functions-basic.php

Then backend will show:
Fatal error: Can't use function return value in write context in /var/www/zenphoto/zp-core/functions-basic.php on line 1760

Is this related with missing exec function?

Any ideas?
Thanks.

Comments

  • acrylian Administrator
    edited November 28

    Generally we don't support PHP 5.3 anymore. Please ask your host to upgrade to at leat PHP 5.6. Sooner or later it will happen anyway since even 5.6 has reached end of line end of this year. All hosts I already know switch.

    As to that line those are related to cURL. But if your server doesn't have that you should not have gotten that far. What does the error log tell?

  • Neither error.log nor debug.log show any entry.

    Just overwriten functions-basic again - to make sure I didn't miss anything - and again, no entries in the log-files.
    But: I just realised, that the BE is not reachable when this file is replaced.

    Regarding php 5.x: I am aware of it and action will be taken, once ZP is up and running live. - that's the current plan :D

  • acrylian Administrator

    But: I just realised, that the BE is not reachable when this file is replaced.

    Don't understand what you mean by this. If you use the plain 1.5 file it will not work with the 1.5 support build because of changes. Otherwise it must be something else like file/folder permissions.

  • thanks for your effort.
    I will leave the 1.4x file in place until the server is upgraded.

    Enjoy!

  • acrylian Administrator

    I cannot test on 5.3, it might be related to that only. Naturally we never can exclude any error. So if you can try on a 5.6 server meanwhile. Perhaps your hosts allows different php versions per directory as mine does.

Sign In or Register to comment.