xmpmetadata: xmp sidecar problem with digikam files

Is it a bug or a feature :)

I recently ran into a problem with https://digikam.org sidecar files and ZP.

I activated the https://www.zenphoto.org/news/xmpmetadata/ plugin. (Thanks for that!)

When adding a picture and the sidecar in ZP, then ZP does not recognise the file.
Then I opened the picture (did not modify it) with Darktable and closed the image.
The existing sidecar file was automatically modified by Darktable.
Now I replaced the sidecar file in ZP with this modified file and then ZP was reading this file.

By comparing both xmp files I saw that Darktable has put this
<?xml version="1.0" encoding="UTF-8"?>
in the first line of its xmp file.

Now I took another digikam xmp-file and was just adding this line
<?xml version="1.0" encoding="UTF-8"?>
in the beginning of the document.
Now ZP was reading the content of the digikam.xmp file. :)

Any idea which command in the plugin must be modified, so it does not require upper line anymore?

Thanks.


And yes, I know I should speed up things and upgrade to ZP 1.5.1 ;)

Comments

  • acrylian Administrator
    edited January 4

    Since we talked already, I tried both test files you sent and both worked here.

    The file is actually plainly read as a text file via the PHP standard function file_get_contents(). So perhaps it is something server specific requiring the XML definition. The plugin itself does not.

Sign In or Register to comment.