I can't get into my new site after logging off

I cannot get into my newly created Zenphoto site.
1. I go to <mysite.com>/gallery
2. The login screen appears and I attempt to login.
3. I get the following error and cannot see or enter the site:

This page isn't working
didn't send any data.
ERR_EMPTY_RESPONSE

Any idea what has gone wrong? This is the initial installation of the site.

  1. I uploaded all files.
  2. I created a database.
  3. I ran the installation process, made sure the installation page showed green icons next to all features, showing that everything needed was good, the installation went well.
  4. I created a master and two other user accounts. The two other accounts had primary folders assigned.
  5. I did alter a couple of options-- mainly turning off unnecessary languages-- but I don't believe I did anything that would have done damage.
  6. That's as far as I got. No photos uploaded, yet.

The site worked well, until I logged out for the first time. Now it is dead. No accounts work. Help! What can I do to reset it, without starting completely over?

Comments

  • acrylian Administrator

    You surely double checked that the passwords are really entered correctly (case especially). Are cookies enabled in your browser? If you have any browser plugins like script/ads tracking blocker or other pricacy related plugins active, try to disable them. Sometimes they can do a bit more than expected.

    In any case please review the debug log you find within zp-data of your installation. And additionally if you can also the PHP error log of your server.

    1. Double-checked passwords.
    2. Cookies enabled.
    3. Turned off Chrome extensions.
    4. Temporarily turned off Norton firewall and antivirus.
      Still fails with error message:

      This page isn't working
      didn't send any data.
      ERR_EMPTY_RESPONSE

    5. zp-data debug log (error_log):

    [19-Feb-2019 02:25:29 UTC] PHP Warning: mysqli_connect():
    (28000/1045): Access denied for user ''@'localhost'
    (using password: NO) in /home//public_html/gallery/zp-core/functions-db-MySQLi.php on line 29

    Password NO? What's making that happen?

    1. PHP debug log: I couldn't find one. Not sure where to look.

    Any other help is appreciated.

  • acrylian Administrator
    edited February 19

    [19-Feb-2019 02:25:29 UTC] PHP Warning: mysqli_connect(): (28000/1045): Access denied for user ''@'localhost' (using password: NO) in /home//public_html/gallery/zp-core/functions-db-MySQLi.php on line 29

    This sounds as if you have to check your database configuration. "Localhost" does not work on most hosts I know. So please contact your host about the correct database user (also if there is a PHP error log somewhere). If ZP cannot access the database properly for some reason this could result in this.

    May I ask how you created your Zenphoto install? In case you used any of these installer helpers any hosts provide, please use the manual way described on our site.

  • I manually installed. I have GoDaddy cPanel host. Localhost works for an existing phpBB database, so I used that for the zenphoto database, too. Now I can't find where to change it.

    Is there a simple way to redo the setup without having to reupload all files? I'm hoping I'm not stuck restarting from scratch.

  • OK, I am starting completely over. It shouldn't take too long. Any suggestion on what "localhost" should be replaced with? Web domain?

  • So far, everything is going well. Localhost was the recommendation of GoDaddy. Not sure what got messed up in the first installation. Consider this thread closed.

  • acrylian Administrator
    edited February 20

    Great, you managed it finally. Sometimes such hiccups occur to everyone… On some hosts "localhost" works and on some you have to enter the actual db host server.

    And you can re-run setup without uploading everything. However the files in zp-core/setup/ would be protected after a successful run so you would have to re-upload those when you can't access the backend to unprotect them.
    You can also edit the db credentials in zp-data/zenphoto.cfg.php.

  • Actually, in hindsight, I'm not sure anything was actually wrong with the site. It appears that the user_login-out plugin was/is the issue. It does not work. Activating the plugin, and trying to use the login window (or link) it presents, consistently leads to the error page previously mentioned. It doesn't matter which option I choose. Anyway, at some point, I will post a new topic and try to figure it out, because I'm a little nervous about sending anyone to admin.php to login.

  • acrylian Administrator
    edited February 23

    Thanks for the note about the plugin. We were/are not aware that there is anything wrong with it since there have been no changes I remember at all. We will try to look into and reproduce it.

    because I'm a little nervous about sending anyone to admin.php to login.

    That's no real problem actually.

Sign In or Register to comment.