BE is deleting current image title and description

I was copy and pasting an existing installation from a live install to a local machine - using phpmyadmin and reading this beforehand:
https://www.zenphoto.org/news/moving-and-changing-existing-installations/

After running the setup script, the frontend is working nicely on the local machine - but - as soon as I open in the back end:
-> "Edit album"
-> pictures
ZenPhoto is deleting the current content of @ least these database fields:

  • title
  • desc
  • copyright
  • tags
    and re-filling them with the metadata content he finds within the pictures/sidecars.

Why is Zenphoto re-reading them?
I would expect, that Zenphoto is happy with the status quo and just continues with new stuff - and not deleting the content of the "old stuff".

Comments

  • acrylian Administrator
    edited February 22

    You need to first move the albums and then import the database backup as the "moving to another server" section tells. Only then visit the front or backend. Zenphoto is file system based and matches the database with the file system and not the other way round. So all albums and images that are not in the database at this time are read as "new" and therefore content will get lost.

  • Hm. I did it "your" way. With upper result.

    I was just testing the "normal local working horse" installation and now, this one is also showing a strange behaviour. :(

    Still investigating...

  • acrylian Administrator

    I moved several sites to other hosts including zenphoto.org itself and it all worked out. Sorry for your problem but I have no clue? Sure about the database part (just to be sure ;)? Anything in the logs? File/folder permissions can cause all sorts of issues, too.

  • Nordlicht Member
    edited February 23

    I am running out of ideas and I am trying to sort things.
    First things first: My ZPC installs are running perfectly on the live server.

    I ONLY face the problem with my local machine, running Debian Stretch and ONLY with ZPC. All other local installs like TYPO3 or Shopware are still running nicely.

    Till Thursday my local ZPC test install was also running nicely.
    Some Debian stable updates were done yesterday early morning.

    Later that day I started to work with my work-environment on the local machine. I realised this problem with this install when working in the "image tab".
    Already existing modified images and their data were all fine. But as soon as I modified anything within an image property of such image and pressed the "apply" button, THEN ZPC deleted all content of

    • image title
    • image description
    • image copyright

    and all thiese fields were blank afterwards!

    I thought the problem is sitting @ the keyboard, even I did not modify any ZPC file.
    I just wanted to be sure to exclude any possible mistake in the local install. So, I just copied and pasted an existing and running install from the live server to the local machine.

    • all these folders and files are 777/666
    • no file is missing

    I'm looking @ the database dump and it looks good.
    I imported it and it still looks good.
    But as soon as I went to the backend, I could see that ZPC was replacing some of the mentioned image properties of some of the pictures - not all pictures! It was simply re-reading and importing the metadata from these pictures.

    If I go in the BE to any picture where the image properties is still fine in the DB, ZPC instantly deletes existing content and replaces it with the metadata it finds in the picture/sidecar.

    If I now, modify this image content again and replace e.g. the description, it will write it in the database and it will not delete anything. So, ZPC behaves as it is expected.

    I am not expecting any wonder :D - I am just sharing my experience.
    Idon't know if I want to invest any more time. Since it has cost me already one working day.... :(

    In German I would say: "Der Laie staunt und der Fachmann wundert sich."

  • acrylian Administrator

    I am sorry but this is no issue I have ever encountered. Zenphoto does not delete anything like that unless anything is wrong.

    The issue is most likely not the file system as it seems but some other stuff. I would think something might not be right with the server/PHP/MySQL on you local enviroment for some weird reason. Especially since you mentioned:

    Till Thursday my local ZPC test install was also running nicely.

    Some Debian stable updates were done yesterday early morning

    So it worked before you applied those updates? Then you probably have the cause… I don't know anything about Debian updates or such as I don't run/manage my own servers. I use hosts and a local MAMP environment that do all this for me.

    777/666

    That's a bit loose perhaps as 755/644 is recommended. But should not really be the issue here (and locally there is not that much security concern).

  • Yes, the local install was working absolutely smooth till Thursday.

    Yes, I decided for 777/666 to avoid any possible headache from this direction.

    And since the Debian update may be the reason, I wrote that non-ZPC installs are still running fine.

    The whole thing is weird.

    Again: "Der Laie staunt und der Fachmann wundert sich."
    :smiley:

  • acrylian Administrator

    And since the Debian update may be the reason, I wrote that non-ZPC installs are still running fine.

    Could be just a PHP extension being missing or not configured properly but without any error message it all is needle in the haystack searching.

  • debug.log and error.log show no entry.
    access.log is "normal" as well.

    No help from that side. Sorry.

    Let it be.
    Enjoy!

Sign In or Register to comment.